PAT菜鸡进化史_乙级_1059
C 语言竞赛是浙江大学计算机学院主持的一个欢乐的竞赛。既然竞赛主旨是为了好玩,颁奖规则也就制定得很滑稽:
- 冠军将赢得一份“神秘大奖”(比如很巨大的一本学生研究论文集……)。
- 排名为素数的学生将赢得最好的奖品 —— 小黄人玩偶!
- 其他人将得到巧克力。
给定比赛的最终排名以及一系列参赛者的 ID,你要给出这些参赛者应该获得的奖品。
输入格式:
输入第一行给出一个正整数 N(≤104),是参赛者人数。随后 N 行给出最终排名,每行按排名顺序给出一位参赛者的 ID(4 位数字组成)。接下来给出一个正整数 K 以及 K 个需要查询的 ID。
输出格式:
对每个要查询的 ID,在一行中输出 ID: 奖品
,其中奖品或者是 Mystery Award
(神秘大奖)、或者是 Minion
(小黄人)、或者是 Chocolate
(巧克力)。如果所查 ID 根本不在排名里,打印 Are you kidding?
(耍我呢?)。如果该 ID 已经查过了(即奖品已经领过了),打印 ID: Checked
(不能多吃多占)。
输入样例:
6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222
输出样例:
8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?
思路:
这题贼有趣哈哈哈,小黄人小黄人!~
Code:
#include <iostream>
#include <cmath>
#include <string>
#include <vector>
struct info{
int ranking, check;
info(){
ranking = -1;
check = 0;
}
};
bool is_prime(int n);
int main(){
using namespace std;
// input the ranking
int total;
cin >> total;
info all_id[10000];
int id;
for (int i = 0; i < total; i++){
cin >> id;
all_id[id].ranking = i + 1;
}
// check the award of the students
int need;
cin >> need;
vector<string> result(need);
for (int i = 0; i < need; i++){
cin >> id;
result[i] += to_string(id) + ": ";
for (int j = 0; result[i].size() < 6; j++)
result[i] = "0" + result[i];
if (all_id[id].ranking == -1){
result[i] += "Are you kidding?";
}else if (all_id[id].check == 1){
result[i] += "Checked";
}else if (all_id[id].ranking == 1){
result[i] += "Mystery Award";
all_id[id].check = 1;
}else if (is_prime(all_id[id].ranking)){
result[i] += "Minion";
all_id[id].check = 1;
}else {
result[i] += "Chocolate";
all_id[id].check = 1;
}
}
// display the result
for (int i = 0; i < need; i++)
cout << result[i] << endl;
return 0;
}
bool is_prime(int n){
if (n < 2)
return 0;
else if (n == 2 || n == 3)
return 1;
for (int i = 2; i <= sqrt(n); i++){
if (!(n % i))
return 0;
}
return 1;
}