HDU 5025

Saving Tang Monk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1665    Accepted Submission(s): 593


Problem Description
《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way.

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.
 

Input
There are several test cases.

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M).

Then the N × N matrix follows.

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).
 

Sample Input
  
  
3 1 K.S ##1 1#T 3 1 K#T .S# 1#. 3 2 K#T .S. 21. 0 0
 

Sample Output
  
  
5 impossible 8
 

题意:K是起点,T是终点。N,M分别表示矩阵的边长和钥匙,意思说必须取M把钥匙才能就唐僧,而且取钥匙的顺序必须是按1-M这样依次取。S表示蛇,第一次经过蛇相当于走两步,再次经过只走一步。

分析:我们先想到的是bfs,但是bfs经过已经经过的点会有些问题。所以我们可以分状态来表示此时这点代表的步数。比如,捡到了第一把钥匙,被第一条和第三条蛇咬了。因此要开个4维数组,前两个记录坐标,后两个分别记录拥有的钥匙数和几条蛇中的哪些蛇咬了。蛇要用状态压缩。

代码:

#include<stdio.h>
struct node
{
    int x,y,key,s;
} que[110*110*110],t,tp,st,e;
char str[110][110];
int N,M,d[110][110][15][40],vis[110][110];
int xx[4]= {0,0,1,-1},yy[4]= {-1,1,0,0};
int ej(int N)
{
    if(N==0)
        return 0;
    int S=1;
    for(int i=2; i<=N; i++)
        S*=2;
    return S;
}
void bfs()
{
    for(int i=0; i<N; i++)
        for(int j=0; j<N; j++)
            for(int i1=0; i1<=M; i1++)
                for(int j1=0; j1<=35; j1++)
                    d[i][j][i1][j1]=999999999;
    int head,title;
    head=title=0;
    t.x=st.x,t.y=st.y,t.key=0,t.s=0;
    d[t.x][t.y][t.key][t.s]=0;
    que[title++]=t;
    while(head<title)
    {
        t=que[head++];
        for(int i=0; i<4; i++)
        {
            tp.x=t.x+xx[i];
            tp.y=t.y+yy[i];
            if(tp.x>=0&&tp.x<N&&tp.y>=0&&tp.y<N&&str[tp.x][tp.y]!='#')
            {
                if(str[tp.x][tp.y]=='.'||str[tp.x][tp.y]=='K'||str[tp.x][tp.y]=='T')
                {
                    tp.key=t.key;
                    tp.s=t.s;
                    if(d[tp.x][tp.y][tp.key][tp.s]>d[t.x][t.y][t.key][t.s]+1)
                    {
                        d[tp.x][tp.y][tp.key][tp.s]=d[t.x][t.y][t.key][t.s]+1;
                        que[title++]=tp;
                    }
                }
                else if(str[tp.x][tp.y]>='0'&&str[tp.x][tp.y]<='9')
                {
                    if(str[tp.x][tp.y]-'0'==t.key+1&&str[tp.x][tp.y]-'0'<=M)
                    {
                        tp.key=t.key+1;
                        tp.s=t.s;
                        if(d[tp.x][tp.y][tp.key][tp.s]>d[t.x][t.y][t.key][t.s]+1)
                        {
                            d[tp.x][tp.y][tp.key][tp.s]=d[t.x][t.y][t.key][t.s]+1;
                            que[title++]=tp;
                        }
                    }
                    else
                    {
                        tp.key=t.key;
                        tp.s=t.s;
                        if(d[tp.x][tp.y][tp.key][tp.s]>d[t.x][t.y][t.key][t.s]+1)
                        {
                            d[tp.x][tp.y][tp.key][tp.s]=d[t.x][t.y][t.key][t.s]+1;
                            que[title++]=tp;
                        }
                    }
                }
                else if(str[tp.x][tp.y]=='S')
                {
                    tp.key=t.key;
                    tp.s=(t.s|vis[tp.x][tp.y]);
                    if((vis[tp.x][tp.y]|t.s)==t.s&&d[tp.x][tp.y][tp.key][tp.s]>d[t.x][t.y][t.key][t.s]+1)
                    {
                        d[tp.x][tp.y][tp.key][tp.s]=d[t.x][t.y][t.key][t.s]+1;
                        que[title++]=tp;
                    }
                    else if((vis[tp.x][tp.y]|t.s)!=t.s&&d[tp.x][tp.y][tp.key][tp.s]>d[t.x][t.y][t.key][t.s]+2)
                    {
                        d[tp.x][tp.y][tp.key][tp.s]=d[t.x][t.y][t.key][t.s]+2;
                        que[title++]=tp;
                    }
                }
            }
        }
    }
}
int main()
{
    while(scanf("%d %d",&N,&M)!=EOF)
    {
        if(M==0&&N==0)
            break;
        int cnt=0;
        for(int i=0; i<N; i++)
            scanf("%s",str[i]);
        for(int i=0; i<N; i++)
            for(int j=0; j<N; j++)
            {
                if(str[i][j]=='K')
                {
                    st.x=i;
                    st.y=j;
                    st.key=0;
                    st.s=0;
                }
                else if(str[i][j]=='T')
                {
                    e.x=i;
                    e.y=j;
                    e.key=M;
                }
                else if(str[i][j]=='S')
                {
                    vis[i][j]=ej(++cnt);
                }
            }
        bfs();
        int most=999999999;
        for(int i=0;i<=ej(cnt+1)-1;i++)
        {
            if(d[e.x][e.y][M][i]<most)
                most=d[e.x][e.y][M][i];
        }
        if(most==999999999)
            printf("impossible\n");
        else
            printf("%d\n",most);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值