Vector-Sort

Vector-Sort

You are given integers.Sort the integers and print the sorted order.
Store the integers in a vector.Vectors are sequence containers representing arrays that can change in size.

· Declaration:

· vector<int>v; (creates an empty vector of integers)

· Size:

· int size=v.size();

· Pushing an integer into a vector:

· v.push_back(x);(where x is an integer.The size increases by 1 after this.)

· Popping the last element from the vector:

· v.pop_back(); (After this the size decreases by 1)

· Sorting a vector:

· sort(v.begin(),v.end()); (Will sort all the elements in the vector)

To know more about vectors, Click Here

Input Format

The first line of the input contains where is the number of integers. The next line contains integers.
Constraints

, where is the integer in the vector.

Output Format

Print the integers in the sorted order one by one in a single line followed by a space.

Sample Input

5

1 6 10 8 4

Sample Output

1 4 6 8 10

题意:从小到大排序。

 

 

#include<cstdio>

#include<iostream>

#include<algorithm>

#include<vector>

using namespace std;

int main()

{

    int n,x;

    cin>>n;

    vector<int>v;

    int i;

    for(i=0;i<n;i++)

    {

        cin>>x;

        v.push_back(x);

    }

    sort(v.begin(),v.end());

    for(i=0;i<n;i++)

    {

        cout<<v[i]<<" ";

    }

    cout<<endl;

    return 0;

}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值