Going Home 网络流(最小费用最大流MCMF)

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.


You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

题意:给你 一张n*m的图;上有人和房子,m代表人的位置,H代表房子的位置,而 .代表空位置,其中人的数量等于房子的数量,人都满足每走一格花费一块钱,问所有人都到其对应的房子中花费的钱数最少是多少?

大体思路:看了大佬的博客,设一个超级源点,s和一个超级汇点t从s->t;最大流的最小费用,s->所有m点的边权:flow=1(流量),w=0(费用);而所有H->t的边权与s->m一样。再加上所用m->H的边f=1,w=l两点距离.用MCMF算法求解:

代码:

#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
using namespace std;
#define inf 0x3f3f3f3f
const int maxn=1e3+100;
struct node
{
    int to,nxt,w,f;
}e[maxn];
int n,m,s,t,maxflow,mincost;
struct nod
{
    int x,y;
}M[maxn],H[maxn];
int head[maxn],cnt;
int dis[maxn],pre[maxn],last[maxn],flow[maxn];
int cnt1,cnt2;
int vis[maxn];
char a[maxn][maxn];
void addedge(int u,int v,int f,int w)
{
    e[cnt].to=v;
    e[cnt].w=w;
    e[cnt].f=f;
    e[cnt].nxt=head[u];
    head[u]=cnt++;
}
int SPFA()
{
    memset(dis,inf,sizeof(dis));
    memset(flow,inf,sizeof(flow));
    memset(vis,0,sizeof(vis));
    queue<int>Q;
    Q.push(s);dis[s]=0;vis[s]=1;
    pre[t]=-1;
    while(!Q.empty())
    {
        int x=Q.front();
//        cout<<x<<endl;
        Q.pop();
        vis[x]=0;
        for(int i=head[x];i!=-1;i=e[i].nxt)
        {
            int to=e[i].to,w=e[i].w,f=e[i].f;
//            cout<<to<<" "<<w<<" "<<f<<endl;
            if(f&&dis[to]>dis[x]+w)
            {
                dis[to]=dis[x]+w;
                flow[to]=min(f,flow[x]);
                pre[to]=x;
                last[to]=i;
                if(!vis[to])
                {
                    Q.push(to);
                    vis[to]=1;
                }
            }
        }
    }
//    cout<<pre[t]<<endl;
    return pre[t]!=-1;
}
void MCMF()
{
    maxflow=mincost=0;
    int x;
    while(SPFA())
    {
        maxflow+=flow[t];
        mincost+=flow[t]*dis[t];
        x=t;
        while(x!=s)
        {
            e[last[x]].f-=flow[x];
            e[last[x]^1].f+=flow[x];
            x=pre[x];
        }
    }
    cout<<mincost<<endl;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
        {
            break;
        }
        memset(head,-1,sizeof(head));
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                cin>>a[i][j];
            }
        }
        s=0,t=200;
        cnt=0;
        cnt1=1;
        cnt2=103;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(a[i][j]=='H')
                {
                    H[cnt2].x=i;
                    H[cnt2].y=j;
                    addedge(t,cnt2,0,0);
                    addedge(cnt2,t,1,0);
                    cnt2++;
                }
                if(a[i][j]=='m')
                {
                    M[cnt1].x=i;
                    M[cnt1].y=j;
                    addedge(s,cnt1,1,0);
                    addedge(cnt1,s,0,0);
                    cnt1++;
                }
            }
        }
//        cout<<cnt1<< " "<<cnt2<<" "<<cnt<<endl;
        for(int i=1;i<cnt1;i++)
        {
            for(int j=103;j<cnt2;j++)
            {
                addedge(i,j,1,abs(M[i].x-H[j].x)+abs(M[i].y-H[j].y));
                addedge(j,i,0,-1*(abs(M[i].x-H[j].x)+abs(M[i].y-H[j].y)));
            }
        }
        MCMF();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值