串 | POJ1035.Spell checker

串 | POJ1035.Spell checker

Link:Spell checker

Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character ‘#’ on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character ‘#’ on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ‘:’ (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

Source
Northeastern Europe 1998

题意
给一个字典,含有至多10000个单词;再给出若干个拼写的单词,其拼写正确与否未知。若拼写单词不在字典中,而经过以下3种操作中的一种,修正之后为字典中的单词,则此单词拼写出现了错误。
1.从单词中删除一个字母
2.用任意一个字母替换单词中的某一个字母
3.插入任意一个字母到单词中
要求判断给出的单词是否拼写正确,如果拼写错误,给出正确的结果(若某个单词经过多种操作都能得到正确的单词,则写出所有正确的单词)

思路
判断是否增删改的方法:
首先比较两个字符串dict,test的长度
1.若长度相等,则只能通过"改"的方式,从左往右扫描,若遇到2个及以上不同的字母,则无法修改。否则,可以修改为字典中的当前比较的字符串
2.若dict长度大于test,则只能增加字符串,遇到第一个不同的字符串,test指针向后一位继续进行比较,若再次遇到不同的字符,则无法修改。
3.若dict长度小于test,则只能减少字符串,遇到第一个不同字符,dict指针向后移动一位。

但是如果有多个修正值可以匹配,题目要求按照字典输入的顺序输出,则不能将字典排序,只能暴力遍历。
代码

#include <iostream>
#include <stdio.h>
#include <cstring>

using namespace std;
char dict[10001][16];
char word[16];
int dict_num = 0;

bool isCorrect( char* word )
{
    for( int i = 0; i < dict_num; i++ )
        if( !strcmp( word, dict[i]) )
            return true;
    return false;
}
void add( char* word, char* dict)
{
    bool modifiable = true;
    int word_len = strlen(word);
    int dict_len = strlen(dict);
    int i = 0, j = 0, dif_cnt = 0;
    while( i < word_len && j < dict_len ) {
        if( word[i] != dict[j] ) {
            dif_cnt++;
            j++;
        } else{
            i++;
            j++;
        }
        if( dif_cnt >= 2 ) {
            modifiable = false;
            break;
        }
    }
    if(modifiable)
        cout << " " << dict;
}

void change( char* word, char* dict){
    bool modifiable = true;
    int word_len = strlen(word);
    int dict_len = strlen(dict);
    int i = 0, j = 0, dif_cnt = 0;
    while( i < word_len && j < dict_len ) {
        if( word[i] != dict[j] ) {
            dif_cnt++;
        }
        i++;
        j++;
        if( dif_cnt >= 2 ) {
            modifiable = false;
            break;
        }
    }
    if(modifiable)
        cout << " " << dict;
}

void del( char* word, char* dict)
{
    bool modifiable = true;
    int word_len = strlen(word);
    int dict_len = strlen(dict);
    int i = 0, j = 0, dif_cnt = 0;
    while( i < word_len && j < dict_len ) {
        if( word[i] != dict[j] ) {
            dif_cnt++;
            i++;
        } else{
            i++;
            j++;
        }
        if( dif_cnt >= 2 ) {
            modifiable = false;
            break;
        }
    }
    if(modifiable)
        cout << " " << dict;
}

int main() {
    while( cin >> dict[dict_num] && dict[dict_num++][0] != '#' );
    dict_num--;
    
    while( cin >> word && word[0] != '#' ){
        if( isCorrect(word) ){
            cout << word << " is correct" << endl;
            continue;
        }
        cout << word << ":";
        for( int i = 0; i < dict_num; i++ ){
            switch( strlen(word) - strlen(dict[i]) ){
                case -1: add( word, dict[i] ); break;
                case 0: change( word, dict[i] ); break;
                case 1: del( word, dict[i] ); break;
                default: break;
            }
        }
        cout << endl;
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值