Python version >= 3.0 do not support this syntax. 如何取消该Pycharm警告。-已解决。

本文系stackOverflow翻译,方便小伙伴们毋需翻墙原文链接:https://stackoverflow.com/questions/41260422/how-to-remove-python-3-warnings-for-print-statements-in-pycharm-when-using-the-p
警告信息:    Python version >= 3.0 do not support this syntax... ...balabalabala... ...此警告的原因是Editer检查器与实际的代码版本环境不对应。在Python2中,print是语句,但在Python3中是一个函数,因此需要print()。
解决方法:
file > Settings > Editor > Inspections > Python > Code compatibility inspection
选择当前项目的实际版本,通常为2.x, 取消其他勾选。路径及操作如图:ok,问题解决。








阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页