poj 1007 DNA Sorting

14 篇文章 0 订阅
8 篇文章 0 订阅

DNA Sorting

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 111655 Accepted: 44686

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Poj 对java不太友好.....

import java.util.ArrayList;
import java.util.Collections;
import java.util.Scanner;

class Num implements Comparable<Num> {
	private String s;
	private int ans;

	public String getS() {
		return s;
	}

	public void setS(String s) {
		this.s = s;
	}

	public int getAns() {
		return ans;
	}

	public void setAns(int ans) {
		this.ans = ans;
	}

	@Override
	public int compareTo(Num o) {
		int num0 = this.getAns() - o.getAns();
		int num1 = num0 == 0 ? this.getS().compareTo(o.getS()) : num0;
		return num1;
	}
}

public class Main {
	public static int calculateres(Num p) {
		String c = p.getS();
		int ans = 0;
		for (int i = 0; i < c.length(); ++i) {
			for (int j = i + 1; j < c.length(); ++j) {
				if (c.charAt(i) > c.charAt(j)) {
					ans++;
				}
			}
		}
		return ans;
	}

	public static void main(String[] args) {
		int n, m;
		ArrayList<Num> q = new ArrayList<Num>();  //利用Collections 工具类中的sort方法可以对List类型的数据进行排序
		Scanner sc = new Scanner(System.in);      //当然ArrayList也可以直接排序,只不过实现Comparator接口的方法在本题会报错,原因不明
		n = sc.nextInt();
		m = sc.nextInt();
		String ss = sc.nextLine();
		Num[] s1 = new Num[m];
		for (int i = 0; i < m; ++i) {
			ss = sc.nextLine();
			s1[i] = new Num();
			s1[i].setS(ss);
		}
		for (int i = 0; i < m; ++i) {
			s1[i].setAns(calculateres(s1[i]));
			q.add(s1[i]);
		}
		Collections.sort(q);
//		q.sort(new Comparator<Num>(){
//			public int compare(Num o1, Num o2) {
//				int num0 = o1.getAns()-o2.getAns();
//				int num1 = num0==0?o1.getS().compareTo(o2.getS()):num0;
//				return num1;
//			}
//		});
		//此法会报错,所以只能实现Comparable接口用Collections工具类进行排序了
		for (int i = 0; i < q.size(); ++i) {
			System.out.println(q.get(i).getS());
		}
		sc.close();
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值