数据结构实验之链表四:有序链表的归并
Time Limit: 1000MS Memory limit: 65536K
题目描述
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
输入
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
输出
输出合并后的单链表所包含的M+N个有序的整数。
示例输入
6 5 1 23 26 45 66 99 14 21 28 50 100
示例输出
1 14 21 23 26 28 45 50 66 99 100
提示
不得使用数组!
来源
示例程序
#include<bits/stdc++.h>
using namespace std;
typedef struct node
{
int data;
struct node *next;
}LNode,*LinkList;
LinkList CreatList(int n)
{
int i;
LNode *head,*p,*tail;
head=new LNode;
head->next=NULL;
tail=head;
for(i=1;i<=n;i++)
{
p=new LNode;
cin>>p->data;
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
}
LinkList MergeList(LinkList head1,LinkList head2)
{
LNode *p1,*p2,*tail;
p1=head1->next;
p2=head2->next;
tail=head1;
free(head2);
while(p1&&p2)
{
if(p1->data<p2->data)
{
tail->next=p1;
tail=p1;
p1=p1->next;
}
else
{
tail->next=p2;
tail=p2;
p2=p2->next;
}
}
if(p1)
{
tail->next=p1;
}
else if(p2)
{
tail->next=p2;
}
return head1;
}
void DisplayList(LinkList L)
{
LNode *p;
p=L->next;
while(p)
{
p->next==NULL?cout<<p->data<<endl:cout<<p->data<<" ";
p=p->next;
}
}
int main ()
{
LinkList head1,head2;
int n,m;
cin>>n>>m;
head1=CreatList(n);
head2=CreatList(m);
head1=MergeList(head1,head2);
DisplayList(head1);
return 0;
}