HDU-1251 统计难题

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 55048    Accepted Submission(s): 19235


 

Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

 

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

 

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

 

Sample Input

banana

band

bee

absolute

acm

 

ba

b

band

abc

 

Sample Output

2

3

1

0

字典树裸题,只需要在添加字符串的时候将路径上的每个节点的cnt都加1即可

看评论区都说G++提交MLE,C++提交正确,,,我也不例外,G++内存7.5w,C++5.5w,搞不懂搞不懂

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

typedef struct trieNode{
	int cnt;
	struct trieNode *next[26];
	
	trieNode(){
		this->cnt = 1 ;
		for( int i=0 ; i<26 ; i++ )
			this->next[i] = NULL;
	}
} *TT;

TT rt = new trieNode();

void insert( char *str ){
	int x;
	TT T = rt;
	for( int i=0 ; str[i] ; i++ ){
		x = str[i] - 'a';
		if( T->next[x]==NULL )
			T->next[x] = new trieNode();
		else
			T->next[x]->cnt++;
		T = T->next[x];
	}
}

int query( char *str ){
	int x;
	TT T = rt;
	for( int i=0 ; str[i] ; i++ ){
		x = str[i] - 'a';
		if( T->next[x]==NULL )
			return 0;
		T = T->next[x];
	}
	return T->cnt;
}

int main(){
//	freopen( "in.txt","r",stdin );
	std::ios::sync_with_stdio( false );
	char str[15];
	while( gets(str) ){
		if( strlen( str )==0 )
			break;
		insert( str );
	}
	while( gets(str) ){
		cout << query( str ) << endl;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值