PAT B1042 字符统计 (20分)

题目链接https://pintia.cn/problem-sets/994805260223102976/problems/994805280817135616

题目描述
请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

样例输入
This is a simple TEST. There ARE numbers and other symbols 1&2&3…

样例输出
e 7

代码

#include <iostream>
#include <string>
using namespace std;

int main() {
	string s1;
	char c1, mc;
	int max = 0;
	int hash[200] = {0};
	getline(cin, s1);
	for(int i = 0; i < s1.size(); i++) {
		c1 = s1[i];
		if(c1 >= 'A' && c1 <= 'Z')
			c1 = c1 - 'A' + 'a';
		if(c1 >= 'a' && c1 <= 'z'){
			hash[c1]++;
			if(hash[c1] > max) {
				max = hash[c1];
				mc = c1;
			}
			else if(hash[c1] == max && c1 < mc)
				mc = c1;
		}
	}
	printf("%c %d\n", mc, max);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值