POJ - 3061

传送门

POJ 3061

题面:

Subsequence
Time Limit: 1000MS Memory Limit: 65536K

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

翻译

   给出了N个正整数序列(10 < N < 100,000),每个正整数小于或等于10000,一个正整数S (S < 100 000 000)。编写一个程序,求序列中连续元素的子序列的最小长度,其和大于或等于S。
输入
  第一行是测试用例的数量。对于每个测试用例,程序都必须读取从第一行开始的数字N和S,它们之间用间隔隔开。序列的编号在测试用例的第二行给出,用间隔隔开。输入将在文件结束时结束。
输出
  对于每种情况,程序都必须在输出文件的单独行上打印结果。如果没有回答,打印0。

思路

使用尺取一个个检索,相对还是简单的~

代码

t为数据的组数,d为当前子序列的和,ss为当前最短符合条件子序列的长度,gg为当前子序列的长度,c用于记录是否有符合条件的子序列

#include<iostream>
#include<cstring>
using namespace std;
int z[100001];
int main()
{	
	int t,n,s,d,gg,ss,c,i,j;
	cin>>t;
	while(t--)
	{
		cin>>n>>s;
		for(i=1;i<=n;i++)
		{
			cin>>z[i];
		} 
		d=0;
		c=0;
		gg=0;
		ss=10000000;
		for(i=1;i<=n;i++)
		{ 
			d+=z[i];
			gg++;
			if(d<s)
			{	
				continue;
			}
			do
			{
				if(ss>gg)
					ss=gg;
				c++;
				d-=z[c];
				gg--;
			}while(d>=s);	
		}
		if(c!=0)
			cout<<ss<<endl;
		else
			cout<<c<<endl;
		memset(z,0,sizeof(z));
	} 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值