decimal system |
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) |
Total Submission(s): 3508 Accepted Submission(s): 1364 |
Problem Description
As we know , we always use the decimal system in our common life, even using the computer. If we want to calculate the value that 3 plus 9, we just import 3 and 9.after calculation of computer, we will get the result of 12.
But after learning <<The Principle Of Computer>>,we know that the computer will do the calculation as the following steps: 1 computer change the 3 into binary formality like 11; 2 computer change the 9 into binary formality like 1001; 3 computer plus the two number and get the result 1100; 4 computer change the result into decimal formality like 12; 5 computer export the result; In the computer system there are other formalities to deal with the number such as hexadecimal. Now I will give several number with a kind of change method, for example, if I give you 1011(2), it means 1011 is a number in the binary system, and 123(10) means 123 if a number in the decimal system. Now I will give you some numbers with any kind of system, you guys should tell me the sum of the number in the decimal system. |
Input
There will be several cases. The first line of each case contains one integers N, and N means there will be N numbers to import, then there will be N numbers at the next N lines, each line contains a number with such form : X1….Xn.(Y), and 0<=Xi<Y, 1<Y<=10. I promise you that the sum will not exceed the 100000000, and there will be at most 100 cases and the 0<N<=1000.
|
Output
There is only one line output case for each input case, which is the sum of all the number. The sum must be expressed using the decimal system.
|
Sample Input
3 1(2) 2(3) 3(4) 4 11(10) 11(2) 11(3) 11(4) |
Sample Output
6 23 |
#include <iostream>
using namespace std;
int pow(int m,int n)//求m的n次幂
{
long int pro = 1;
while(n--)
pro *= m;
return pro;
}
int main()
{
int T,p,q;//k为指数
char left_arc,right_arc;
while (cin >> T)
{
int sum = 0;
while(T--)
{
int k = 0;
cin >> p >> left_arc >> q >> right_arc;
while (p != 0)
{
sum += p % 10 * pow(q,k++);
p /= 10;
}
}
cout << sum << endl;
}
return 0;
}