HDU 5475 An easy problem 2015ICPC 上海网络赛

An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 538    Accepted Submission(s): 302


Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

Input
The first line is an integer T( 1T10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

Sample Input
  
  
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

Sample Output
  
  
Case #1: 2 1 2 20 10 1 6 42 504 84
 

题意:起始值val为1,有N组操作,每组操作两个参数u、v,如果u为1,那么val*=v,如果u为2,那么u/=v`,v`为前面第v个操作的第二个参数,输出每组操作的结果。

分析:直接暴力搞会WA的,因为你存不下那么大的数,如果你离线存储操作的话会TLE,呃,比赛的时候想多了,就是一个简单的线段树单点更新嘛。乘的话就把对应节点的值修改为要乘的值,除的话就把要除的那个位置的数所代表的乘的值改为1就行,即不乘那一步了。然后每次询问输出总区间的和可以了。

#include <cstdio>
#include <iostream>
#include <cstring>
#include<vector>
#include <queue>
#include <algorithm>
using namespace std;
const int N = 200305;
typedef long long LL;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
LL ans[N<<2];
LL mod;
void PushUp(int rt)
{
    ans[rt] = (ans[rt<<1] * ans[rt<<1|1]) % mod;
}
void build(int l,int r ,int rt)
{
    if(l==r)
    {
        ans[rt] = 1;
        return ;
    }
    int m = (l+r)>>1;
    build(lson);
    build(rson);
   PushUp(rt);
}
void update(int L,LL c,int l,int r,int rt=1)
{
    if (L == l && l == r)
    {
        ans[rt] = c;
        return ;
    }
    int m = (l + r) >> 1;
    if (L <= m) update(L , c , lson);
    else update(L , c , rson);
    PushUp(rt);
}
LL query(int L,int R,int l,int r,int rt=1)
{
    if (L <= l && r <= R)
        return ans[rt];
    int m = (l + r) >> 1;
    int ret = 1;
    if (L <= m) ret = ret*query(L , R , lson) % mod;
    if (m < R) ret = ret*query(L , R , rson) % mod;
    return ret;
}
int main()
{
    int T,tp,cs = 1;
    LL c;
    int n;
    scanf("%d",&T);

    while(T--)
    {
       scanf("%d%lld",&n,&mod);
       build(1,n,1);
       printf("Case #%d:\n",cs++);
       for(int i = 1;i<=n;i++)
       {
           scanf("%d%lld",&tp,&c);
           if(tp==1) update(i,c,1,n,1);
           else update(c,1,1,n,1);

           printf("%lld\n",query(1,n,1,n,1));
       }
    }
    return 0;
}

题目链接: 点击打开链接





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值