nyoj 另类乘法

标题 另类乘法

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, AB is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 12345 is equal to 14 + 15 + 24 + 25 + 34 + 35 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie’s style of multiplication.

输入格式
The first Line of the input is a positive integer T,indicates the number of the test cases;
In every case,the input is in one line,contains two positive interger A,B

输出格式
For every case,output the multiplication in Bessie’s style.

样例
样例输入
1
123 45
样例输出
54

//奇技淫巧,我们用字符串数组来代替整型数组,不需要再对数分解取余。
```c
#include <stdio.h>
#include <string.h>
char a[1000000], b[1000000];
int main()
{
	int n;
	scanf("%d",&n);
	while (n --)
	{
		scanf("%s %s",a, b);
		int la = strlen(a);
		int lb = strlen(b);
		int sum = 0;
		for (int i = 0; i < la; i ++)
		{
			for (int j = 0; j < lb; j ++)
			{
				sum += (a[i] - '0') * (b[j] - '0');
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值