Description
给你一个n个数的数列,其中某个数出现了超过n div 2次即众数,请你找出那个数。
Input
第1行一个正整数n。 第2行n个正整数用空格隔开。
Output
一行一个正整数表示那个众数。
Sample Input
5
3 2 3 1 3
Sample Output
3
HINT
100%的数据,n<=500000,数列中每个数<=maxlongint。
zju2132 The Most Frequent Number
题解
这题好神呐!
首先不管什么。。理他众数是谁,我们设这个数列中众数的权都为1
然后其他都是-1
那么可以想出,在这个数列里,除了众数,如果把其他设为1的结果都会被消掉
所以说。。。这样模拟就好了
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
int n,tot=0,num,x;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&x);
if(tot==0){num=x;tot++;}
else if(num==x)tot++;
else tot--;
}
printf("%d\n",num);
return 0;
}