C++ 高精度乘法

题目描述:

给定两个位数不超过255位的正整数,求它们的乘积。

输入描述:

输入文件中包含两个不超过255位正整数

输出描述:

对输入的正整数,输出其乘积。

样例输入

1111

9

样例输出

9999

算法原理如图

第一步:输入字符串,并将其转化成数组

	cio
	cin>>s1;
	cin>>s2;
	la=s1.size(),lb=s2.size();
	for(int i=0;i<la;i++){
		a[la-i]=s1[i]-'0';
	}
	for(int i=0;i<lb;i++){
		b[lb-i]=s2[i]-'0';
	}

 第二步(重头戏):计算c[i+j-1]的值

for(int i=1;i<=la;i++){
		x=0;
		for(int j=1;j<=lb;j++){
			c[i+j-1]=a[i]*b[j]+x+c[i+j-1];
			x=c[i+j-1]/10;
			c[i+j-1]%=10;
		}
		c[i+lb]=x;
	}

 第三步:删除前导0


                
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理
C++ 精度乘法可以使用 vector 容器来实现。具体步骤如下: 1. 定义两个 vector 容器存储两个精度数,例如 vector<int> a 和 vector<int> b。 2. 定义一个 vector 容器存储结果,例如 vector<int> c,初始时将其填充为 0。 3. 从两个精度数的最低位开始,按照竖式乘法的规则逐位相乘,将结果存储在 c 中相应的位置。 4. 处理进位,将 c 中每一位上的数字对 10 取模并记录进位,将进位值加到下一位的计算结果中。 5. 删除 c 中前导 0。 6. 将 c 中每一位上的数字转换为字符并拼接成字符串,即为精度乘法的结果。 以下是基于 vector 实现的 C++ 精度乘法示例代码: ```c++ #include <iostream> #include <vector> using namespace std; vector<int> multiply(vector<int> a, vector<int> b) { vector<int> c(a.size() + b.size(), 0); // 存储结果,初始值为 0 for (int i = 0; i < a.size(); i++) { int carry = 0; // 进位值 for (int j = 0; j < b.size(); j++) { int tmp = a[i] * b[j] + c[i + j] + carry; // 乘法计算 c[i + j] = tmp % 10; // 取模 carry = tmp / 10; // 进位 } if (carry) c[i + b.size()] += carry; // 处理最位的进位 } while (c.size() > 1 && c.back() == 0) c.pop_back(); // 删除前导 0 return c; } int main() { string num1, num2; cin >> num1 >> num2; vector<int> a, b; for (int i = num1.size() - 1; i >= 0; i--) a.push_back(num1[i] - '0'); for (int i = num2.size() - 1; i >= 0; i--) b.push_back(num2[i] - '0'); vector<int> c = multiply(a, b); for (int i = c.size() - 1; i >= 0; i--) cout << c[i]; cout << endl; return 0; } ``` 该代码中,输入的两个精度数 num1 和 num2 都是字符串类型,需要将其转换为 vector 容器进行计算。输出结果时,需要将计算结果的 vector 容器中的数字逆序输出。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值