POJ 3624 Charm Bracelet (01背包)

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output
* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23

大概思路:

本来是想通过一个二维数组进行记录,但因为本题的要求,用二维数组会超内存。所以利用滚动数组进行记录以节省空间。
这种01背包类的问题的状态转移方程为(i为第i个物体,j为剩下可用的容量):
dp[i][j]=Max(dp[i-1][j],dp[i-1][j-weight[i]]+value[i])
即第i个物品的取与不取,这个判断的前提是j>=weight[i],否则dp[i][j]=dp[i-1][j]。
而利用滚动组节省空间的方法则是从有开始往左边扫,这样就不会出现错误的情况。

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int dp[13000];
int main()
{
   // freopen("in.txt","r",stdin);
    int n,m;
    int w[3500],v[3500];
    cin>>n>>m;
    for(int i=1;i<=n;++i)
        cin>>w[i]>>v[i];
    for(int i=1;i<=m;++i){//初始化边界条件
        if(w[1]<=i)
            dp[i]=v[1];
        else
            dp[i]=0;
    }
    for(int i=2;i<=n;++i){
        for(int j=m;j>=0;--j){
            if(w[i]<=j)
                dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
            else
                dp[j]=dp[j];
        }
    }
    cout<<dp[m]<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值