POJ 3069 Saruman's Army

                                               Saruman's Army
                        Time Limit: 1000MS  Memory Limit: 65536K 

Description
Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.
Input
The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n= −1.
Output
For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output
2
4
Hint
In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.
In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题目分析:题目的大概意思其实可以理解为在一条数轴上有N个点,然后让你画尽量少的圆使这N个点都落在圆内,给出圆的半径为R;
算法设计:我们开始以第一个点(位置为i)为标记位,从i开始进行循环,依次以下一个点为圆心画圆看是否能将第一个点包括在内,只要可以,我们就不断向前找,直到找到一个点s,使s-i的距离大于r为止。如果这个s就是它本身的位置,那么我们就可以将计数器加一,记录一次。如果不是,那么我们以s为起点,找以s-1为圆心,可以包括的点。最后将不在圆内的点记为t,并将它赋给i,作为下一回循环的起点。直到处理完所有的点为止。
算法解读:此题利用贪心的思想。从左开始,每次都找到一个可以包含最多点的为标记,直到覆盖所有的点。

#include <cstdio>
#include <algorithm>
#include <iostream>
using namespace std;
int a[1500];
int main()
{
    int r,n,sum,s,t,i;
    while (scanf("%d%d",&r,&n) && r!=-1 && n!=-1)
    {
        for (i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        i=0;
        sum=0;
        while (i<n)
        {
            s=i;
            while (a[s]-a[i]<=r)
            {
                s++;
            }
            if (s==i-1)
            {
                sum++;
                i++;
            }
            else
            {
                t=s;
                while (a[t]-a[s-1]<=r)
                {
                    t++;
                }
                sum++;
                i=t;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值