Monthly Expense POJ - 3273 ( 二分法)

Monthly Expense

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500                                                                                                                                                                                                                 

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:

给出农夫在n天中每天的花费,要求把这n天分成m组,每组的天数必须连续的,要求各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值。

就是用二分来做,二分找最大值来划分组,如果可以划分为m个组即可以找到各组中的最大值。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
int n,m;  //n天 m组
int a[100007];
int HF(int mid)
{
	int ans=0; //组数
	int sum=0; //各个组的和
	for(int i=0;i<n;i++)
	{
		if(sum+a[i]<=mid) //如果这个组的和≤mid,那么就还可以加入这一天的花费
		{
			sum+=a[i];
		}
		else  //否则就将这一天划到下一组中
		{
			sum=a[i];
			ans++;
		}
	}
	ans++; //最后一份也是一组 
	if(ans<=m)return 1;  //如果组数≤m,说明mid找大了
	else return 0;
}
int main()
{
	scanf("%d%d",&n,&m);
	int maxn=0;  //花费最高的一天
	int sum=0;   //n天的总费用
	for(int i=0;i<n;i++)
	{
		scanf("%d",&a[i]);
		maxn=max(maxn,a[i]);
		sum+=a[i];
	}
	int l=maxn,r=sum;
	int mid;
	while(l<=r)
	{
		mid=(l+r)/2;
		if(HF(mid)) //通过mid划分的组数≤m,mid划分大了
		{
			r=mid-1;
		}
		else
		{
			l=mid+1;
		}
	}
	printf("%d\n",mid);
	return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值