Fence Repair POJ - 3253 (贪心+优先队列)

Fence Repair 

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the Nplanks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34                                                                                                                                                                                                     

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题意:

要将一块木板分成n块,然后给出了每块的长度,切割都要有花费,每次切割的花费就是切割的木板的长度,要求最小的花费。

错误思路:

我以为每次只要把所需要的最长的先切去所花费用就最短,这种想法是错的。并不是最小的花费。因为我们每次切出来的两块不一定就是我们直接就需要的,一般是需要继续切,才能得到我们需要的。

wrong代码wrong代码:

#include<iostream>         
#include<algorithm>
using namespace std;
int main()
{
    int a[20010];
    int n,ans,sum;
    while(cin>>n)
    {
        for(int i=0;i<n;++i)
        {
            cin>>a[i];
            sum+=a[i];
        }
        sort(a,a+n);
        for(i=n-1;i>0;--i)
        {
            ans+=sum;
            sum-=a[i];
        }
        cout<<ans<<endl;
    }
    return 0;
}

正确的思路:

要花费最少,那么就希望每次所切割的木板都是最短的,所以就可以反过来想,从切割后的n块木板每次找两块最短的合并。用优先队列来写十分方便。

代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<cmath>
#include<algorithm> 
using namespace std;
int main()
{
    long long n,l,sum=0;
	scanf("%lld",&n);
	priority_queue<int, vector<int>, greater<int> > q; //定义优先队列q,每次取出的都是最小的
	for(int i=0;i<n;i++)
	{
		scanf("%lld",&l);
		q.push(l); //入队
	}
	
	while(q.size()>1)
	{
		long long l1,l2;   //从队列中取出最短的两个长度
		l1=q.top();   
		q.pop();
		l2=q.top();
		q.pop();
		
		sum+=l1+l2;
		q.push(l1+l2);  //将合并的长度入队
		
	}
	printf("%lld\n",sum); 
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值