Find a way HDU - 2612

Find a way

Problem Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input

The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66

分别以两个人为起点进行两次BFS,然后找出步数最少的kfc店.

开始的时候我存了所有的kfc店位置,遍历kfc,然后BFS,这样就是BFS了(2*kfc店个数)次,超级无敌超时了...

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm> 
using namespace std; 
int n, m;
struct node{
	int x,y;
	int step;
};  
struct node yifenfei;
struct node friends;
queue<struct node> q; 
int kfc[207][207];
int kind = 0;//kfc个数 
char mp[207][207];  //地图
int vis[207][207];  
int nnext[4][2]={{1,0}, {-1,0}, {0,1}, {0,-1}};
void bfs()
{  
    while(!q.empty())q.pop();
    memset(vis,0,sizeof(vis));
    node ynew;
    q.push(yifenfei);
    vis[yifenfei.x][yifenfei.y] = 1;
    while(q.size())
    {
    	ynew = q.front();
    	q.pop();
    	if(mp[ynew.x][ynew.y] == '@')
    	{  
    		kfc[ynew.x][ynew.y] = ynew.step;
		}
		for(int i = 0; i < 4; i++)
		{
			int tx = ynew.x + nnext[i][0];
			int ty = ynew.y + nnext[i][1];
			if(tx >= 0 && tx < n && ty >= 0 && ty < m && mp[tx][ty] != '#' && vis[tx][ty] == 0)
			{
				vis[tx][ty] = 1;
				node f;
				f.x = tx;
				f.y = ty;
				f.step = ynew.step + 11;
				q.push(f);
			}
		}
	}
	while(!q.empty())q.pop();
    memset(vis,0,sizeof(vis));
    q.push(friends);
    vis[friends.x][friends.y] = 1;
	while(!q.empty())
    {
    	ynew = q.front();
    	q.pop();
    	if(mp[ynew.x][ynew.y] == '@')
    	{  
    		kfc[ynew.x][ynew.y] += ynew.step;
		}
		for(int i = 0; i < 4; i++)
		{
			int tx = ynew.x + nnext[i][0];
			int ty = ynew.y + nnext[i][1];
			if(tx >= 0 && tx < n && ty >= 0 && ty < m && mp[tx][ty] != '#' && vis[tx][ty] == 0)
			{
				vis[tx][ty] = 1;
				node f;
				f.x = tx;
				f.y = ty;
				f.step = ynew.step + 11;
				q.push(f);
			}
		}
	}
	return;
}

int main()
{
	while(scanf("%d%d", &n, &m) !=EOF && n && m)
	{ 
		memset(kfc, 0, sizeof(kfc));
		for(int i = 0; i < n; i++)
		{
			getchar();
			scanf("%s", mp[i]);
			for(int j = 0; j < m; j++)
			{
				if(mp[i][j] == 'Y')
				{
					yifenfei.x = i;
					yifenfei.y = j;
					yifenfei.step = 0;
				}
				else if(mp[i][j] == 'M')
				{
					friends.x = i;
					friends.y = j;
					friends.step = 0;
				} 
			}
		}
		bfs(); 
		int res = 1000000000;
		for(int i = 0; i < n; i++){
            for(int j = 0; j < m; j++){
                if(kfc[i][j] < res && kfc[i][j] != 0) res = kfc[i][j];
            }
        }
		printf("%d\n", res); 
	}
	return 0; 	
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值