大整数运算

大整数运算

以一个简单题目来开始我们今天的笔记

1024 Palindromic Number (25 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.
Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
AC代码如下:

#include <string>
#include <algorithm>
#include <iostream>
using namespace std;
int Palindromic(string str){
    int len = str.size();
    int tail = len - 1;
    for (int i = 0; i <= len/2; ++i) {
        if(str[i] != str[tail])
            return 0;
        tail--;
    }
    return 1;
}
string add(string str1,string str2){
    string ans = str1;
    int len = str1.size(),carry = 0;
    for (int i = len - 1; i >= 0; i--) {
        ans[i] = (str1[i] - '0' + str2[i] - '0' + carry)%10 + '0';
        carry = (str1[i] - '0' + str2[i] - '0' + carry)/10;
        if(i == 0 && carry != 0){
            ans.insert(0,1,'1');
        }
    }
    return ans;
}
int main(){
    int k,cishu = 0;
    string str,str_rev;
    cin >> str >> k;
    while (k--){
        if(Palindromic(str)){
            cout << str << endl;
            cout << cishu;
            return 0;
        }
        str_rev = str;
        reverse(str_rev.begin(),str_rev.end());
        str = add(str,str_rev);
        cishu++;
    }
    cout << str << endl;
    cout << cishu;
    return 0;
}

这是一道常见的大整数加法题目,题目本身不是很难,但因为对STL标准库的不熟练,导致本题还是花了较长时间。
一,回文串的判断
一般是比较字符串(长度为n)的前一半和后一半即可。
如长度为偶数的字符串,以4为例,比较0、1和2、3;即小于n/2即可,等号不用取
长度为奇数的字符串,以3为例,比较0和2,中间不用比,即小于n/2即可。

bool judge(char str[]){
    int len = strlen(str);
    for (int i = 0; i < len/2; ++i) {
        if(str[i] != str[len - 1 - i])
            return false;
    }
    return true;
}

二、大整数相加
有时由于数据过大导致结果超出int 或long long 的范围,故而采取字符串存储进行计算防止由此带来的数据溢出。
在进行字符串输入时,如:123456789,**整数的高位存储在数组的低位,整数的低位存储在数组的高位。这样存储会在计算产生进位时造成困扰,故一般反向存储数据。**然后在计算完毕打印时再逆向输出即可。

struct bign{
    int num[100];
    int len;
}bi[30];

bign change(char str[]){
    bign a;
    a.len = strlen(str);
    for (int i = 0; i < a.len; ++i) {
        a.num[i] = str[a.len - i] - '0';
    }
    return a;
}

大整数运算主要有四种,加减乘除
加法:按照我们计算等式的步骤来即可,但要注意先算本位的值再算进位以免出错
减法:减法运算按照等式的方法可知,计算前需要比较数据的大小,然后用大数减小数。被减数某位的值小即借位加10,相应被减数的前一位减1.
乘法:也阔以按照小学等式的方法来计算,用被乘数来乘以乘数的每一位,但这样乘也有可能会产生溢出。故在高精度*低精度的运算中可以用被乘数的每一位乘以乘数,防止溢出。
除法:除法也类似,每相除,余数乘10参与下一位得运算。
在此贴一个柳神得AC代码,膜拜一下。

#include <iostream>
#include <algorithm>
using namespace std;
string s;
void add(string t) {
    int len = s.length(), carry = 0;
    for(int i = 0; i < len; i++) {
        s[i] = s[i] + t[i] + carry - '0';
        carry = 0;
        if(s[i] > '9') {
            s[i] = s[i] - 10;
            carry = 1;
        }
    }
    if(carry) s += '1';
    reverse(s.begin(), s.end());
}
int main() {
    int cnt, i;
    cin >> s >> cnt;
    for(i = 0; i <= cnt; i++) {
        string t = s;
        reverse(t.begin(), t.end());
        if(s == t || i == cnt) break;
        add(t);
    }
    cout << s << endl << i;
    return 0;
}

参考:https://blog.csdn.net/liuchuo/article/details/52280891

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值