POJ 3150/ UVA 1386 Cellular Automaton(矩阵乘法&循环矩阵)

Description

cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order of the cellular automaton is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.

The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m − 1.

One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of order m. We will denote such kind of cellular automaton as n,m-automaton.

A distance between cells i and j in n,m-automaton is defined as min(|i − j|, n − |i − j|). A d-environment of a cell is the set of cells at a distance not greater than d.

On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell i modulo m.

The following picture shows 1-step of the 5,3-automaton.

The problem is to calculate the state of the n,m-automaton after k d-steps.

Input

The first line of the input file contains four integer numbers nmd, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n2 , 1 ≤ k ≤ 10 000 000). The second line contains n integer numbers from 0 to m − 1 — initial values of the automaton’s cells.

Output

Output the values of the n,m-automaton’s cells after k d-steps.

Sample Input

sample input #1
5 3 1 1
1 2 2 1 2

sample input #2
5 3 1 10
1 2 2 1 2

Sample Output

sample output #1
2 2 2 2 1

sample output #2
2 0 0 2 2

Source


题意:给你一个循环的数组,经过一次变换,每一个数变成原来数组里自己和距离自己不超过d的数字的和模m。

求k次变换后数组的值。


对于第一个样例,可以很轻松的构造出矩阵:

A: 

1 2 2 1 2


B:

1 1 0 0 1

1 1 1 0 0 

0 1 1 1 0

0 0 1 1 1 

1 0 0 1 1


然后答案就是A*(B^k),然而,n有500那么大,复杂度就是O(n^3*log(k)),所以会超时。

但是我们观察发现B是一个循环矩阵,循环矩阵有一个性质 如果A是循环矩阵,那么A^2, A^3.....都是循环矩阵。

那么我们做矩阵乘法的时候就只用算出矩阵的第一行,下面每一行都可以由上一行推出,那么这样复杂度都变成了O(n^2*log(k)).

还有就是500*500在结构体里开不下,无奈只能用普通数组。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define LL long long

using namespace std;

int n,m,d,k;


LL A[500][500],B[500][500],ans[500][500],t[500][500];

void mul(LL a[500][500],LL b[500][500],LL ans[500][500])
{
    int i,j;
    memset(t,0,sizeof(t));
    for(i=0;i<n;i++)
        for(j=0;j<n;j++)
        {
            t[0][i] += a[0][j]*b[j][i];
            t[0][i] %= m;
        }
    for(i=1;i<n;i++)
        for(j=0;j<n;j++)
            t[i][j] = t[i-1][(j-1+n)%n];
    for(i=0;i<n;i++)
        for(j=0;j<n;j++)
            ans[i][j] = t[i][j];
}

void pow(LL a[500][500],int k)
{
    int i,j;
    for(i=0;i<n;i++)
        for(j=0;j<n;j++)
            ans[i][j] = (i==j);
        while(k)
        {
            if(k&1)
                mul(ans,B,ans);
            mul(B,B,B);
            k /= 2;
        }
    for(i=0;i<n;i++)
        for(j=0;j<n;j++)
            a[i][j] = ans[i][j];
}
int main(void)
{
    int i,j;
    while(scanf("%d%d%d%d",&n,&m,&d,&k)==4)
    {
        memset(A,0,sizeof(A));
        memset(B,0,sizeof(B));
        for(i=0;i<n;i++)
            scanf("%lld",&A[0][i]);
        for(j=0;j<n;j++)
        {
            for(i=0;i<=d;i++)
            {
                B[(j+i)%n][j] = 1;
                B[(j-i+n)%n][j] = 1;
            }
        }
        pow(B,k);
        mul(A,B,ans);
        for(i=0;i<n-1;i++)
            printf("%d ",ans[0][i]);
        printf("%d\n",ans[0][i]);
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值