【HDU】 2846 Repository

8 篇文章 0 订阅

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3442    Accepted Submission(s): 1291


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
  
  
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
  
  
0 20 11 11 2
 


题解:直接暴力出每个字符串的子串加入Trie,最后查找。

注意abab在插入的时候ab只需要加一次,要做好记号。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>

using namespace std;

struct Trie
{
    Trie *ch[27];
    int val,f;
};
Trie *root;
char c[25],s[25];
int P,Q;

void buildtrie(char *s,int flag)
{
    Trie *p=root,*q;
    int l=strlen(s),k;
    for (int i=0;i<l;i++)
    {
        k=s[i]-97;
        if (p->ch[k]==NULL)
        {
            q=(Trie*)malloc(sizeof(Trie));
            for (int j=0;j<26;j++) q->ch[j]=NULL;
            q->val=1; q->f=flag;
            p->ch[k]=q;
            p=p->ch[k];
        }
        else
        {
            if (p->f!=flag)
            {
                p->f=flag;
                p->val++;
            }
            p=p->ch[k];
        }
    }
    if (p->f!=flag)
    {
        p->f=flag;
        p->val++;
    }
}

void solve(char *s,int flag)
{
    int p,l=strlen(s);
    for (int i=0;i<l;i++)
        for (int j=i;j<l;j++)
    {
        p=0;
        for (int k=i;k<=j;k++,p++) c[p]=s[k];
        buildtrie(c,flag);
        memset(c,0,sizeof(c));
    }
}

int intrie(char *s)
{
    Trie *p=root;
    int k,l=strlen(s);
    for (int i=0;i<l;i++)
    {
        k=s[i]-97;
        if (p->ch[k]!=NULL) p=p->ch[k];
        else return 0;
    }
    return p->val;
}

int main()
{
    root=(Trie*)malloc(sizeof(Trie));
    for (int i=0;i<26;i++) root->ch[i]=NULL;
    root->val=0; root->f=0;
    scanf("%d",&P);
    for (int i=1;i<=P;i++)
    {
        scanf("%s",s);
        solve(s,i);
    }
    scanf("%d",&Q);
    while (Q--)
    {
        scanf("%s",s);
        printf("%d\n",intrie(s));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值