本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:
-
无论用户说什么,首先把对方说的话在一行中原样打印出来;
-
消除原文中多余空格:把相邻单词间的多个空格换成 1
个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉; -
把原文中所有大写英文字母变成小写,除了 I;
-
把原文中所有独立的 can you、could you 对应地换成 I can、I could——
这里“独立”是指被空格或标点符号分隔开的单词; -
把原文中所有独立的 I 和 me 换成 you;
-
把原文中所有的问号 ? 换成惊叹号 !; 在一行中输出替换后的句子作为 AI 的回答。
输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。
输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。
输入样例:
6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know
输出样例:
Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don’t know
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStream;
import java.io.InputStreamReader;
import java.io.File;
import java.io.FileNotFoundException;
import java.io.FileReader;
import java.util.StringTokenizer;
public class Main {
public static void main(String[] args) throws IOException {
Reader.init(System.in);
int N = Reader.nextInt();
for (int i = 0; i < N; i++) {
String str = Reader.nextLine();
System.out.println(str);
StringBuilder ans = new StringBuilder();
ans.append("AI:");
// 初始化 在标点符号前加一个空格
str = init(str);
// 分割处理
String[] tmp = str.split(" ");
String pre = "";
for (String item : tmp) {
// 略过空字符串
if (!item.equals("")) {
// 大写转小写 和 ?转!
item = toLowCase(item);
if (start_char(item)) {
// 把标点符号前面的空格删掉
ans.append(item);
} else {
if (item.equals("you")) {
// can you could you转换
if(pre.equals("can")) {
ans.replace(ans.length() - 3, ans.length(), "I can");
}else if(pre.equals("could")) {
ans.replace(ans.length() - 5, ans.length(), "I could");
}else {
ans.append(" " + item);
}
}else if(item.equals("I")||item.equals("me")) {
ans.append(" you");
}else {
ans.append(" " + item);
}
}
pre = item;
}
}
// 判断是否是标点符号开头
if(!ans.toString().contains("AI: ")) {
ans.replace(0, 3, "AI: "