2017 ICPC 南宁 M.The Maximum Unreachable Node Set(floyd 二分图最大匹配 求最大独立集)

题目描述
In this problem, we would like to talk about unreachable sets of a directed acyclic graph G = (V, E). In mathematics a directed acyclic graph (DAG) is a directed graph with no directed cycles. That is a graph such that there is no way to start at any node and follow a consistently-directed sequence of edges in E that eventually loops back to the beginning again.
A node set denoted by V UR ⊂ V containing several nodes is known as an unreachable node set of G if, for each two different nodes u and v in V UR , there is no way to start at u and follow a consistently-directed sequence of edges in E that finally archives the node v. You are asked in this problem to calculate the size of the maximum unreachable node set of a given graph G.
输入
The input contains several test cases and the first line contains an integer T (1 ≤ T ≤ 500) which is the number of test cases.
For each case, the first line contains two integers n (1 ≤ n ≤ 100) and m (0 ≤ m ≤ n(n − 1)/2) indicating the number of nodes and the number of edges in the graph G. Each of the following m lines describes a directed edge with two integers u and v (1 ≤ u, v ≤ n and u 6= v) indicating an edge from the u-th node to the v-th node. All edges provided in this case are distinct.
We guarantee that all directed graphs given in input are DAGs and the sum of m in input is smaller than 500000.
输出
For each test case, output an integer in a line which is the size of the maximum unreachable node set of G.

样例输入

3
4 4
1 2
1 3
2 4
3 4
4 3
1 2
2 3
3 4
6 5
1 2
4 2
6 2
2 3
2 5

样例输出

2
1
3

分析

就是要我们求出图的最大独立集
当且仅当对于U 中任意点u 和v所构成的边(u , v) 不是G 的一条边时,U 定义了一个空子图。当且仅当一个子集不被包含在一个更大的点集中时,该点集是图G 的一个独立集(independent set ),同时它也定义了图G 的空子图。最大独立集是具有最大尺寸的独立集。

我们先用floyd算法求出各个点之间的联通关系,然后再用匈牙利算法求出了最小点权覆盖,最大独立集+最小点权覆盖=总权值,所以 n 减去这些点就是答案。

注意:
DAG的最小可相交路径覆盖和最小不可相交路径覆盖的区别在于是否要传递连通性。

代码
#include<bits/stdc++.h>
#define ll long long
#define mset(a,x) memset(a,x,sizeof(a))
 
using namespace std;
int s[105][105],n,m,vis[105],link[105];
 
int dfs(int num)
{
	for(int i=1;i<=n;i++)  
    {
		if(s[num][i]&&!vis[i])
		{
			vis[i]=1;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=num;
				return 1;
			}
		}
	}
	return 0;
}
 
int main()
{
	int i,j,k,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		mset(s,0);
		while(m--)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			s[x][y]=1;
		}
		//求可达矩阵
		for(k=1;k<=n;k++)
		{
			for(i=1;i<=n;i++)
			{
				for(j=1;j<=n;j++)
				{
					if(s[i][k]&&s[k][j]) 
					s[i][j]=1; 
				}
			}
		}
		mset(link,-1);
		int ans=0;
		for(i=1;i<=n;i++)
		{
			mset(vis,0);
			if(dfs(i))
			ans++;
		}
		printf("%d\n",n-ans);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值