Hust oj 1521 Marshal's Confusion III(整数快速幂)

Marshal's Confusion III
Time Limit: 3000 MSMemory Limit: 65536 K
Total Submit: 282(71 users)Total Accepted: 89(60 users)Rating: Special Judge: No
Description
Marshallike to solve acm problems.But they are very busy, one day they meet a problem. Given three intergers a,b,c, the task is to compute a^(b^c))%317000011. so the turn to you for help. 
Input
The first line contains an integer T which stands for the number of test cases. Each case consists of three integer a, b, c seperated by a space in a single line. 1 <= a,b,c <= 100000
Output
For each case, print a^(b^c)%317000011 in a single line.
Sample Input
2
1 1 1
2 2 2
Sample Output

1
16

Author

王勇

简单的整数快速幂,只不过从a^b mod c变成了a^b^c mod c,变形之后就是a^(b^c mod c-1)mod c,然后套模板

#include<iostream>
#include<cstring>

using namespace std;

const int mod=317000011;
long long  quickpow(long long   m , long long   n , long long   k)
{
    long long int ans = 1;
    while(n){
        if(n&1)
            ans = (ans * m) % k;
        n = n >> 1;
        m = (m * m) % k;
    }
    return ans;
}
int main()
{
    int n;
    long long int a,b,c;
    cin>>n;
    while(n--)
    {
        cin>>a>>b>>c;
        cout<<quickpow(a,quickpow(b,c,mod-1),mod)<<endl;;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值