Pku oj 1905 Expanding Rods(简单几何加二分)

Expanding Rods
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 249(100 users)Total Accepted: 121(93 users)Rating: Special Judge: No
Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced.

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output
61.329
225.020

0.000

几何方式求L’,然后再与用题中公式求得进行比较,以此来二分答案

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdlib>
using namespace std;

const double eqs = 1e-8;
double l,n,s,c;
double h;
double r;

int main()
{
    while(~scanf("%lf%lf%lf",&l,&n,&c))
    {
        if(l < 0 && n < 0 && c < 0) break;
        s = (1 + n * c) * l;
        double low = 0,high = 0.5 * l,mid;
        while(high - low > eqs)
        {
            mid = (high + low) / 2;
            r = (4*mid*mid + l*l) / (8*mid);
            if(2*r*asin(l/(2*r)) < s)
                low = mid;
            else
                high = mid;
        }
        printf("%.3lf\n",mid);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值