Hust oj 1384 Leyni, LOLI and Toasts(水题)

Leyni, LOLI and Toasts
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 53(43 users)Total Accepted: 43(43 users)Rating: Special Judge: No
Description

Leyni likes to play with LOLIs, but this winter is so cold in Harbin!

A group of n LOLIs decided to buy b bottles of soft drink to make themselves warmer. Each bottle has d milliliters of the drink. Also they bought l limes and cut each of them into k slices. After that they found p grams of salt.

To make a toast, each LOLI needs x milliliters of the drink, a slice of lime and y grams of salt. Having the average materials, the LOLIs want to make toasts as many as they can. How many toasts can each LOLI makes?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. Then T test cases follow.

For each test case:

Line 1. This line contains eight positive integers, nbdlkpx(1 ≤ n, b, d, l, k, p, x, y ≤ 1000). The numbers are separated by exactly one space.

Output

For each test case:

Line 1. Output the number of toasts each LOLI can make.

Sample Input

1

3 4 5 10 8 100 3 1

Sample Output

2

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int t;
int n,b,d,l,k,p,x,y;

int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d%d%d%d%d",&n,&b,&d,&l,&k,&p,&x,&y);
        printf("%d\n",min((b*d)/x,min(l*k,p/y))/n);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值