Hust oj 2118 Friend number(递推)

Friend number
Time Limit: 1000 MSMemory Limit: 32768 K
Total Submit: 91(55 users)Total Accepted: 63(53 users)Rating: Special Judge: No
Description

Friend number are defined recursively as follows.

(1) numbers 1 and 2 are friend number;

(2) if a and b are friend numbers, so is ab+a+b;

(3) only the numbers defined in (1) and (2) are friend number.

Now your task is to judge whether an integer is a friend number.


Input

There are multiple test cases. 

For each test case:

Line 1: A nonnegative integer a, 0<=a<=2^30.


Output

For each test case, output one line, if a is a friend number, output "YES!", otherwise output "NO!".

Sample Input
3
13121
12131
Sample Output
YES!
YES!
NO!
设Friendnumber = a+b+ab+1-1,变形为(a+1)(b+1)-1,然后再用(c+1)(d+1)-1代替其中的a,以此类推,直到最后推到a=1,b=2,代入得2^x + 3^y - 1.
#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int flag = 0;
        if(!n)
        {
            printf("NO!\n");
            continue;
        }
        for(int i=0;i<=30;i++)
        {
            for(int j=0;j<=30;j++)
            {
                if(int(pow(2,i)) * int(pow(3,j)) - 1 == n)
                {
                    printf("YES!\n");
                    flag = 1;
                    break;
                }
            }
            if(flag)
                break;
        }
        if(!flag)
            printf("NO!\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值