Hdu oj 4632 Palindrome subsequence(区间dp)

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 3054    Accepted Submission(s): 1252


Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <S y1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.
 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

Sample Input
  
  
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

Sample Output
  
  
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960
dp[i][j]表示从i到j之间有多少个回文串,先从距离为1的区间开始处理,逐渐加大
状态转移方程:dp[i][j] = dp[i][j-1] + dp[i+1][j] - dp[i+1][j-1];     (str[i] != str[j])             dp[i][j] += dp[i+1][j-1] + 1;                 (str[i] == str[j])
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

const int maxn = 1005;
const int Mod = 10007;
int t;
int dp[maxn][maxn];
char str[maxn];

int main()
{
    scanf("%d",&t);
    int cnt = 0;
    while(t--)
    {
        scanf("%s",&str);
        int len = strlen(str);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<len;i++)
        {
            dp[i][i] = 1;
        }
        for(int k=0;k<len;k++)
        {
            for(int i=0;k+i<len;i++)
            {
                int j = i + k;
                dp[i][j] = dp[i][j-1] + dp[i+1][j] - dp[i+1][j-1];
                if(str[i] == str[j])
                    dp[i][j] += dp[i+1][j-1] + 1;
                dp[i][j] = (dp[i][j] + Mod) % Mod;
            }
        }
         printf("Case %d: %d\n",++cnt,dp[0][len-1]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值