Pku oj 3468 A Simple Problem with Integers(线段树Lazy标记)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 95170 Accepted: 29652
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15
 
不用lazy标记会超时
#include<stdio.h>
#include<iostream>>
#include<algorithm>
#define N 100050
using namespace std;

typedef long long int ll;
struct Node
{
    int left,right;
    ll sum;
    ll mark;
}tree[N<<2];

int num[N];

void create(int root, int left, int right)
{
    tree[root].left = left;
    tree[root].right = right;
    tree[root].mark = 0;
    if(left == right)
    {
        tree[root].sum = num[left];
        return ;
    }
    int mid = (left + right) >> 1;
    create(root << 1, left, mid);
    create(root << 1 | 1, mid + 1, right);
    tree[root].sum = tree[root<<1].sum + tree[root<<1|1].sum;
}

void update(int root, int left, int right,int val)
{
    if(tree[root].left == left && tree[root].right == right)
    {
        tree[root].mark += val;
        return ;
    }
    tree[root].sum += (ll)val * (right - left + 1);
    int mid = (tree[root].left + tree[root].right) >> 1;
    if(right <= mid)
        update(root << 1, left, right,val);
    else if(left > mid)
        update(root << 1 | 1, left, right,val);
    else
    {
        update(root << 1, left, mid, val);
        update(root << 1 | 1, mid + 1, right, val);
    }
}

ll query(int root, int left, int right)
{
    if(tree[root].left == left && tree[root].right == right)
    {
        return tree[root].sum + tree[root].mark * (ll)(right-left+1);
    }
    if(tree[root].mark)
    {
        tree[root<<1].mark += tree[root].mark;
        tree[root<<1|1].mark += tree[root].mark;
        tree[root].sum += (ll)(tree[root].right - tree[root].left + 1) * tree[root].mark;
        tree[root].mark = 0;
    }
    int mid = (tree[root].left + tree[root].right)>>1;
    if(right <= mid)
        return query(root << 1, left, right);
    else if(left > mid)
        return query(root << 1 | 1, left, right);
    else
    {
        return query(root << 1, left, mid) + query(root << 1 | 1, mid + 1, right);
    }
}

int main()
{
    int n,q,cnt = 0;
    char str[8];
    while(~scanf("%d%d",&n,&q))
    {
        for(int i = 1; i <= n; i++)
            scanf("%d", &num[i]);
        create(1, 1, n);
        for(int i = 1;i <= q; i++)
        {
            int x,y,z;
            scanf("%s",&str);
            if(str[0] == 'Q')
            {
                scanf("%d%d",&x,&y);
                printf("%lld\n",query(1,x,y));
            }
            if(str[0] == 'C')
            {
                scanf("%d%d%d",&x,&y,&z);
                update(1,x,y,z);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值