L1-027

一时间网上一片求救声,急问这个怎么破。其实这段代码很简单,index数组就是arr数组的下标,index[0]=2 对应 arr[2]=1,index[1]=0 对应 arr[0]=8,index[2]=3 对应 arr[3]=0,以此类推…… 很容易得到电话号码是18013820100。

本题要求你编写一个程序,为任何一个电话号码生成这段代码 —— 事实上,只要生成最前面两行就可以了,后面内容是不变的。

输入格式:

输入在一行中给出一个由11位数字组成的手机号码。

输出格式:

为输入的号码生成代码的前两行,其中arr中的数字必须按递减顺序给出。

输入样例:
18013820100
输出样例:
int[] arr = new int[]{8,3,2,1,0};
int[] index = new int[]{3,0,4,3,1,0,2,4,3,4,4};

#include <iostream>
#include <string>
#include <set>
#include <array>
#include <algorithm>
using namespace std;
int main()
{
    set<int>s;
    string num;
    int a[11];
    int flag = 0;
    cin >> num;
    for (int i = 0; i < 11; i++)
        s.insert(num[i]-'0');
    //for (auto i=s.rbegin();i!=s.rend();i++)
        //cout << *i;
    cout << "int[] arr = new int[]{";
    for (auto i = s.rbegin(); i != s.rend(); i++)
    {
        a[*i] =flag ;
        flag++;
        if (i == s.rbegin())cout << *i;
        else 
            cout <<','<< *i;
    }
    cout << "};" << endl;
    cout << "int[] index = new int[]{";
    for (int i = 0; i < 11; i++) {
        if (i == 0)cout << a[num[i]-'0'];
        else
            cout << ',' << a[num[i]-'0'];
    }
    cout << "};";

    system("pause");

}

知识点,rebegin and rend,it’s still from rebegin to the rend,but you should make it ++ and it will form the end to the begin;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值