2019上海网络赛(J)Stone gameDP背包

CSL loves stone games. He has n stones; each has a weight ai. CSL wants to get some stones. The rule is that the pile he gets should have a higher or equal total weight than the rest; however if he removes any stone in the pile he gets, the total weight of the pile he gets will be no higher than the rest. It’s so easy for CSL, because CSL is a talented stone-gamer, who can win almost every stone game! So he wants to know the number of possible plans. The answer may be large, so you should tell CSL the answer modulo 10^9 + 7.

Formerly, you are given a labelled multiset S = a 1 , a 2 , … , a n S={a1,a2,…,an} S=a1,a2,,an, find the number of subsets of S: S ′ = { a i 1 , a i 2 , … , a i k } S'=\{a_{i_1}, a_{i_2}, \ldots, a_{i_k} \} S={ai1,ai2,,aik}, such that

( S u m ( S ′ ) ≥ S u m ( S − S ′ ) ) ∧ ( ∀ t ∈ S ′ , S u m ( S ′ ) − t ≤ S u m ( S − S ′ ) ) \left(Sum(S') \ge Sum(S-S') \right) \land \left(\forall t \in S', Sum(S') - t \le Sum(S-S') \right) (Sum(S)Sum(SS))(tS,Sum(S)tSum(SS)) .

InputFile

The first line an integer T (1≤T≤10), which is the number of cases.

For each test case, the first line is an integer n(1≤n≤300), which means the number of stones. The second line are n space-separated integers a 1 , a 2 , … , a n a_1,a_2,…,a_n a1,a2,,an (1≤ai≤500).

OutputFile

For each case, a line of only one integer t — the number of possible plans. If the answer is too large, please output the answer modulo 10^9 + 7.

样例输入复制

2
3
1 2 2
3
1 2 4

样例输出复制

2
1

样例解释

In example 1, CSL can choose the stone 1 and 2 or stone 1 and 3.

In example 2, CSL can choose the stone 3.

链接:

https://nanti.jisuanke.com/t/41420

题意:

有一堆石头,现在让你选从中选出几个石头,使得选出石头的总和大于等于剩余石头的总和并且从选出的石头中拿出任何一块石头小于等于剩余石头的总和。

思路:

因为从选出的石头中选出如何一块石头,那么我们要拿出最小的一块石头。所以我们可以从大到小排序一下。dp[k]表示选出石头重量为k的方案数,然后就01背包。因为我们的石头是从大到小排的,那么选第i块石头为最小石头并且总重量为k的方案数就是dp[k-a[i]]。

代码:
#include<bits/stdc++.h>
using namespace std;
const int maxn = 10000000;
const int MOD = 1e9+7;
int a[maxn];
int dp[maxn];
bool cmp(int x, int y)
{
    return x > y;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--) {
        int n;
        scanf("%d", &n);
        memset(dp, 0, sizeof(dp));
        int sum = 0;
        for(int i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
            sum += a[i];
        }
        dp[0] = 1;
        int ans = 0;
        sort(a+1, a+1+n, cmp);
        for(int i = 1; i <= n; i++) {
            for(int j = sum; j >= a[i]; j--) {
                dp[j] = (dp[j] + dp[j-a[i]]) % MOD;
                if(j >= sum - j && j - a[i] <= sum - j) {
                    ans = (ans+dp[j-a[i]])%MOD;
                }
            }
        }
        printf("%d\n", ans%MOD);
        
    }
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值