1130. Infix Expression (25)
Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N ( <= 20 ) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:
data left_child right_child
where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by -1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
|
|
|
|
Output Specification:
For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.
Sample Input 1:8 * 8 7 a -1 -1 * 4 1 + 2 5 b -1 -1 d -1 -1 - -1 6 c -1 -1Sample Output 1:
(a+b)*(c*(-d))Sample Input 2:
8 2.35 -1 -1 * 6 1 - -1 4 % 7 8 + 2 3 a -1 -1 str -1 -1 871 -1 -1Sample Output 2:
(a*2.35)+(-(str%871))
这个题当时做的时候压根没思路,直接被括号给搞晕了,连根节点也不会找,然后没办法还是看的别人的题解。根节点就是把所有子节点全部标记以下,没有标记的就是根节点(当时真是想都没想到),然后括号这个如果一个结点有右子树(可能没有左子树,所以就判断右子树,有了左子树必然有右子树),如果有就加括号。括号在中序遍历中输出,具体的看代码。
#include<bits/stdc++.h>
using namespace std;
struct node{
string data;
int left;
int right;
}a[25];
int visit[25],n,root;
void inorder(int now){
if(now==-1) return;
if(a[now].right!=-1&&now!=root) printf("(");
inorder(a[now].left);
cout<<a[now].data;
inorder(a[now].right);
if(a[now].right!=-1&&now!=root) printf(")");
}
int main(){
scanf("%d",&n);
for(int i=1;i<=n;i++){
cin>>a[i].data>>a[i].left>>a[i].right;
if(a[i].left!=-1) visit[a[i].left]=1;
if(a[i].right!=-1) visit[a[i].right]=1;
}
for(int i=1;i<=n;i++){
if(!visit[i]) root=i;
}
inorder(root);
printf("\n");
return 0;
}