POJ 2480 BZOJ 2705 Longge的问题

105 篇文章 0 订阅
11 篇文章 0 订阅

Description

Longge is good at mathematics and he likes to think about hard mathematical problems which will be solved by some graceful algorithms. Now a problem comes: Given an integer N(1 < N < 2^31),you are to calculate ∑gcd(i, N) 1<=i <=N. 

"Oh, I know, I know!" Longge shouts! But do you know? Please solve it. 

Input

Input contain several test case. 
A number N per line. 

Output

For each N, output ,∑gcd(i, N) 1<=i <=N, a line

Sample Input

2
6

Sample Output

3
15

Source

POJ Contest,Author:Mathematica@ZSU

(POJ的描述比较生动有趣,就贴了POJ的~)

(翻译见BZOJ 2705~)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

思路见:http://www.cnblogs.com/JS-Shining/archive/2012/05/14/2500661.html

分解n得k|n,则题目变为求k*φ(n/k)~

然后就套欧拉函数~


#include<cstdio>
#define ll long long

ll ans,n,a;

int main()
{
	while(scanf("%lld",&n)!=EOF)
	{
		ans=n;
		for(ll i=2;i*i<=n;i++)
		{
			if(n%i==0)
			{
				a=0;
				while(n%i==0)
				{
					a++;n/=i;
				} 
				ans+=ans*a*(i-1)/i;
			} 
		}
		if(n!=1) ans=ans*(n*2-1)/n;
		printf("%lld\n",ans);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值