Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd aaaa ababab .
Sample Output
1 4 3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
KMP~
这里的字符串是从0开始的,所以求next[i]的时候k要-1~
很巧妙的用了next数组~
(输入字符串s可以不加&~)
#include<cstdio>
#include<cstring>
#define maxn 1000006
int len,k,next[maxn];
char s[maxn];
void g(char u[],int v)
{
for(int i=1;i<v;i++)
{
k=next[i-1];
while(k>0 && u[i]!=u[k]) k=next[k-1];
if(u[i]==u[k]) next[i]=k+1;
else next[i]=0;
}
}
int main()
{
scanf("%s",s);
while(s[0]!='.')
{
len=strlen(s);
next[0]=0;
g(s,len);
if(len%(len-next[len-1])==0) printf("%d\n",len/(len-next[len-1]));
else printf("1\n");
scanf("%s",s);
}
return 0;
}