UVa 1636 Headshot

42 篇文章 0 订阅

You have a revolver gun with a cylinder that has n chambers. Chambers are located in a circle on acylinder. Each chamber can be empty or can contain a round. One chamber is aligned with the gun’sbarrel. When trigger of the gun is pulled, the gun’s cylinder rotates, aligning the next chamber with thebarrel, hammer strikes the round, making a shot by firing a bullet through the barrel. If the chamberis empty when the hammer strikes it, then there is no shot but just a “click”.You have found a use for this gun. You are playing Russian Roulette with your friend. Your friendloads rounds into some chambers, randomly rotates the cylinder, aligning a random chamber with agun’s barrel, puts the gun to his head and pulls the trigger. You hear “click” and nothing else — thechamber was empty and the gun did not shoot.Now it is your turn to put the gun to your head and pull the trigger. You have a choice. Youcan either pull the trigger right away or you can randomly rotate the gun’s cylinder and then pull thetrigger. What should you choose to maximize the chances of your survival?

Input

The input file contains several datasets. A dataset consists of a single line with a string of n digits ‘0’and ‘1’ (2 ≤ n ≤ 100). This line of digits represents the pattern of rounds that were loaded into thegun’s chambers. ‘0’ represent an empty chamber, ‘1’ represent a loaded one. In this representation,when cylinder rotates before a shot, the next chamber to the right gets aligned with the barrel for ashot. Since the chambers are actually located on a circle, the first chamber in this string follows thelast one. There is at least one ‘0’ in this string.

Output

For each dataset, write to the output file one of the following words (without quotes):• ‘SHOOT’ — if pulling the trigger right away makes you less likely to be actually shot in the headwith the bullet (more likely that the chamber will be empty).• ‘ROTATE’ — if randomly rotating the cylinder before pulling the trigger makes you less likely tobe actually shot in the head with the bullet (more likely that the chamber will be empty).• ‘EQUAL’ — if both of the above choices are equal in terms of probability of being shot.

Sample Input

0011

0111

000111

Sample Output

EQUAL

ROTATE

SHOOT

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

概率~

条件概率+比率:

条件概率是00在01+00中发生的概率,后一个是求0的比率。

设00序列的个数是a,0的个数是b,串的长度是n,那么两个概率分别是a/b,b/n,最终比较a*n和b*b的大小即可。


#include<cstdio>
#include<cstring>

int n,a,b;
char s[101];

int main()
{
	while(scanf("%s",s)==1)
	{
		n=strlen(s);a=b=0;
		for(int i=0;i<n;i++) if(s[i]=='0') b++;
		for(int i=0;i<n;i++) if(s[i]=='0' && s[(i+1)%n]=='0') a++;
		if(a*n>b*b) printf("SHOOT\n");
		else if(a*n==b*b) printf("EQUAL\n");
		else printf("ROTATE\n");
	}
	return 0;
} 


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值