HDU 5823 color II

48 篇文章 0 订阅
38 篇文章 0 订阅
Problem Description
You are given an undirected graph with n vertices numbered 0 through n-1.

Obviously, the vertices have 2^n - 1 non-empty subsets. For a non-empty subset S, we define a proper coloring of S is a way to assign each vertex in S a color, so that no two vertices in S with the same color are directly connected by an edge. Assume we've used k different kinds of colors in a proper coloring. We define the chromatic number of subset S is the minimum possible k among all the proper colorings of S.

Now your task is to compute the chromatic number of every non-empty subset of the n vertices.
 

Input
First line contains an integer t. Then t testcases follow.

In each testcase: First line contains an integer n. Next n lines each contains a string consisting of '0' and '1'. For 0<=i<=n-1 and 0<=j<=n-1, if the j-th character of the i-th line is '1', then vertices i and j are directly connected by an edge, otherwise they are not directly connected.

The i-th character of the i-th line is always '0'. The i-th character of the j-th line is always the same as the j-th character of the i-th line.

For all testcases, 1<=n<=18. There are no more than 100 testcases with 1<=n<=10, no more than 3 testcases with 11<=n<=15, and no more than 2 testcases with 16<=n<=18.
 

Output
For each testcase, only print an integer as your answer in a line.

This integer is determined as follows:
We define the identity number of a subset S is id(S)=vS2v . Let the chromatic number of S be fid(S) .

You need to output 1<=id(S)<=2n1fid(S)×233id(S)mod232 .
 

Sample Input
  
  
2 4 0110 1010 1101 0010 4 0111 1010 1101 1010
 

Sample Output
  
  
1022423354 2538351020
Hint
For the first test case, ans[1..15]= {1, 1, 2, 1, 2, 2, 3, 1, 1, 1, 2, 2, 2, 2, 3}
 

Author
学军中学
 

Source
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
状压DP+图的染色~
(真是高端啊)
1<<n少了一个<检查了好长时间……然后,这里直接long long强制转化为unsigned int就不用取模了很巧妙啊~

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
#define ll long long

int t,n;
ll f[1<<18],ans,now;
bool b[1<<18];
char s[20][20];

int main()
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(b,0,sizeof(b));
		for(int i=1;i<=n;i++) scanf("%s",s[i]+1);
		for(int i=1;i<(1<<n);i++)
		  for(int j=0;j<n;j++)
		  {
		  	if(i&(1<<j))
		      for(int k=0;k<n;k++)
		        if(i&(1<<k) && s[j+1][k+1]=='1')
		        {
		        	b[i]=1;break;
				}
			if(b[i]) break;
		  }
		f[0]=0;
		for(int i=1;i<(1<<n);i++)
		{
			f[i]=999999999;
			for(int j=i;j;j=(j-1)&i)
			  if(!b[j]) f[i]=min(f[i],f[i^j]+1);
		}
		ans=0,now=1;
		for(int i=1;i<(1<<n);i++)
		{
			now*=233;
			ans+=now*f[i];
		}
		printf("%u\n",(int)ans);
	}
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值