POJ 2348 Euclid's Game

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 
         25 7

         11 7

          4 7

          4 3

          1 3

          1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

Source

Waterloo local 2002.09.28

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

博弈+扩展欧几里得算法~

从题目就可以看出来这道题要用扩展欧几里得算法~

对于两组石子x,y(x>y,且x/y=k),可以一次性取出y,y*2,y*3,…,y*k颗石子,对于取石子的人来说,如果以后有必胜策略,就一次性取y*k颗石子,如果必输,就剩下一组,使得另一人只能取走剩下的y颗,由此可以看出遇到k>1的人必胜。

所以就先预处理,把石子分为几堆,每堆数量表示k的值,循环直到k!=1,就输出。


#include<cstdio>
#include<iostream>
using namespace std;

int x,y,a[100001],now;

int main()
{
	while(scanf("%d%d",&x,&y)==2 && x)
	{
		if(x<y) swap(x,y);now=1;a[0]=0;
		while(now)
		{
			a[++a[0]]=x/y;now=x%y;
			x=y;y=now;
		}now++;
		for(int i=1;i<=a[0] && a[i]==1;i++) now++;
		if(now>a[0])
		{
			if(now%2) printf("Ollie wins\n");
			else printf("Stan wins\n");
		}
		else
		{
			if(now%2) printf("Stan wins\n");
	        else printf("Ollie wins\n");
		}
	}
	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值