POJ 2226 Muddy Fields

105 篇文章 0 订阅
9 篇文章 0 订阅

Description

Rain has pummeled the cows' field, a rectangular grid of R rows and C columns (1 <= R <= 50, 1 <= C <= 50). While good for the grass, the rain makes some patches of bare earth quite muddy. The cows, being meticulous grazers, don't want to get their hooves dirty while they eat. 

To prevent those muddy hooves, Farmer John will place a number of wooden boards over the muddy parts of the cows' field. Each of the boards is 1 unit wide, and can be any length long. Each board must be aligned parallel to one of the sides of the field. 

Farmer John wishes to minimize the number of boards needed to cover the muddy spots, some of which might require more than one board to cover. The boards may not cover any grass and deprive the cows of grazing area but they can overlap each other. 

Compute the minimum number of boards FJ requires to cover all the mud in the field.

Input

* Line 1: Two space-separated integers: R and C 

* Lines 2..R+1: Each line contains a string of C characters, with '*' representing a muddy patch, and '.' representing a grassy patch. No spaces are present.

Output

* Line 1: A single integer representing the number of boards FJ needs.

Sample Input

4 4
*.*.
.***
***.
..*.

Sample Output

4

Hint

OUTPUT DETAILS: 

Boards 1, 2, 3 and 4 are placed as follows: 
1.2. 
.333 
444. 
..2. 
Board 2 overlaps boards 3 and 4.

Source

USACO 2005 January Gold

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

神奇的建图+匈牙利算法~

给每一个可以放木板的区域标号,当两个横纵区域有交点时就连边,然后跑一遍匈牙利算法就可以了~


#include<cstdio>
#include<cstring>

int n,m,col[2501],ans,tot1,tot2,a[2501][2501];
char s[52][52];
bool b[2501][2501],jud[2501];

void buil()
{
	for(int i=1;i<=n;i++)
	{
		int j=1;
		while(j<=m)
		{
			if(s[i][j]=='*')
		 	{
		 		int now=j;tot1++;
				while(s[i][j]=='*') j++;
				for(int k=now;k<j;k++) a[i][k]=tot1;
			}
			else j++;
		}
	}
	for(int i=1;i<=m;i++)
	{
		int j=1;
		while(j<=n)
		{
			if(s[j][i]=='*')
			{
				int now=j;tot2++;
				while(s[j][i]=='*') j++;
				for(int k=now;k<j;k++)
				  if(a[k][i]) b[tot2][a[k][i]]=1;
			}
			else j++;
		}
	}
}

bool colo(int u)
{
	for(int i=1;i<=tot2;i++)
	  if(!jud[i] && b[i][u])
	  {
	  	jud[i]=1;
	  	if(!col[i] || colo(col[i]))
		{
			col[i]=u;return 1;
		}
	  }
	return 0;
}

int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++) scanf("%s",s[i]+1);buil();
	for(int i=1;i<=tot1;i++)
	{
		for(int j=1;j<=tot2;j++) jud[j]=0;
		if(colo(i)) ans++;
	}
	printf("%d\n",ans);
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值