UVa 1639 Candy

99 篇文章 0 订阅
42 篇文章 0 订阅
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy
boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first
box with probability p and the second box with probability (1 − p). For the chosen box, if there are
still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds
no candy left. Before opening the other box, he wants to know the expected number of candies left in
the other box. Can you help him?
Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2×105
) and a real number
p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
Output
For each test case, output one line ‘Case X: Y ’ where X is the test case number (starting from 1)
and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10−4 would be accepted.
Sample Input
10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520
2276 0.720000
Sample Output
Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816

Case 6: 1390.500000

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

概率+(神奇的)思路+次方应用~

乘什么的容易拉低精度,所以换算成e的次方数来加和乘;exp(i)使用cmath头文件,表示e^i。

枚举第二个盒子里的剩余糖果数i,则其概率为C(2*n-i,n)*k^(n+1)*(1-k)^(n-i)~

(究竟是哪位神犇想出来这么神奇的卡精度思路的?)


#include<cstdio>
#include<cmath>

int n,cnt;
double p,ans;
long double lo[400001];

long double logg(int u,int v)
{
	return lo[u]-lo[v]-lo[u-v];
}

int main()
{
	for(int i=1;i<=400000;i++) lo[i]=lo[i-1]+log(i);
	while(scanf("%d",&n)!=EOF)
	{
		scanf("%lf",&p);ans=0;
		printf("Case %d: ",++cnt);
		long double p1=log(p),p2=log(1-p);
		for(int i=1;i<=n;i++)
		{
			long double kkz=logg(2*n-i,n);
			long double k1=kkz+(n+1)*p1+(n-i)*p2;
			long double k2=kkz+(n+1)*p2+(n-i)*p1;
			ans+=i*(exp(k1)+exp(k2));
		}
		printf("%.6lf\n",ans);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值