UVa 753 A Plug for UNIX

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet
eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas
on the Internet as cumbersome and bureaucratic as possible.
Since the room was designed to accommodate reporters and journalists from around the world, it is
equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances
in all of the countries that existed when the room was built. Unfortunately, the room was built many
years ago when reporters used very few electric and electronic devices and is equipped with only one
receptacle of each type. These days, like everyone else, reporters require many such devices to do their
jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the
meeting is likely to be long and tedious, you want to be able to plug in as many as you can.
Before the meeting begins, you gather up all the devices that the reporters would like to use, and
attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle.
You wonder if these devices are from countries that didn’t exist when the room was built. For some
receptacles, there are several devices that use the corresponding plug. For other receptacles, there are
no devices that use the corresponding plug.
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters
that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to
be plugged into other adapters. The store does not have adapters for all possible combinations of plugs
and receptacles, but there is essentially an unlimited supply of the ones they do have.
Input
The input will consist of several case. The first line of the input contains the number of cases, and it’s
followed by a blank line.
The first line of each case contains a single positive integer n (1 ≤ n ≤ 100) indicating the number of
receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle
type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive
integer m (1 ≤ m ≤ 100) indicating the number of devices you would like to plug in. Each of the next
m lines lists the name of a device followed by the type of plug it uses (which is identical to the type
of receptacle it requires). A device name is a string of at most 24 alphanumeric characters. No two
devices will have exactly the same name. The plug type is separated from the device name by a space.
The next line contains a single positive integer k (1 ≤ k ≤ 100) indicating the number of different
varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving
the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.
There’s a blank line between test cases.
Output
For each case, print a line containing a single non-negative integer indicating the smallest number of
devices that cannot be plugged in.
Print a blank line between cases.
Sample Input
1
4
A
B
C
D
5
laptop B
phone C
pager B
clock B
comb X
3
B X
X A
X D
Sample Output

1

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

最大流~

原来的代码把i当成a[i]用了,白检查了好久……

记录下所有的点,记录到char型数组里面,然后每次加的时候查一下是否已有,返回位置。建立源点0,汇点++tot,源点向每个插座连容量为1的边,插头向汇点连容量为1的边,每个连接器的插座向插头连边,因为连接器有无限个,所以边权为inf,再跑一遍最大流就可以了~

最后的时候要加上一个特判,少输出一个回车,否则会PE。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
using namespace std;

int t,n,m,k1,k2,k,fi[10001],w[100001],ne[100001],v[100001],cnt,ans,dis[10001],tot,a[10001];
char s[25],s1[25],name[10001][25];

void add(int u,int vv,int val)
{
	w[++cnt]=vv;v[cnt]=val;ne[cnt]=fi[u];fi[u]=cnt;
	w[++cnt]=u;v[cnt]=0;ne[cnt]=fi[vv];fi[vv]=cnt;
}

int chek(char *ss)
{
	for(int i=1;i<=tot;i++)
	  if(!strcmp(ss,name[i])) return i;
	strcpy(name[++tot],ss);
	return tot;
}

bool bfs()  
{  
	memset(dis,0,sizeof(dis));
    queue<int> q;q.push(0);dis[0]=1;  
    while(!q.empty())  
    {  
        int k=q.front();q.pop();  
        for(int i=fi[k];i;i=ne[i])  
          if(!dis[w[i]] && v[i]>0)  
          {  
            dis[w[i]]=dis[k]+1;q.push(w[i]);  
            if(w[i]==tot) return 1;  
          }  
    }  
    return 0;  
}  
  
int findd(int u,int vv)  
{  
    if(u==tot) return vv;  
    int kkz;  
    for(int i=fi[u];i;i=ne[i])  
      if(v[i]>0 && dis[u]+1==dis[w[i]] && (kkz=findd(w[i],min(vv,v[i]))))  
      {  
        v[i]-=kkz;v[i^1]+=kkz;return kkz;  
      }  
    return 0;  
}  

int main()
{
	scanf("%d",&t);
	while(t--)
	{
		ans=a[0]=tot=0;cnt=1;
		memset(fi,0,sizeof(fi));
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%s",s);int now=chek(s);
			add(0,now,1);
		}
		scanf("%d",&m);
		for(int i=1;i<=m;i++)
		{
			scanf("%s",s);scanf("%s",s);
			a[++a[0]]=chek(s);
		}
		scanf("%d",&k);
		for(int i=1;i<=k;i++)
		{
			scanf("%s%s",s,s1);
			int nu1=chek(s),nu2=chek(s1);
			add(nu2,nu1,999999999);
		}
		tot++;int now;
		for(int i=1;i<=a[0];i++) add(a[i],tot,1);
		while(bfs())
		  while(now=findd(0,999999999)) ans+=now;
		printf("%d\n",m-ans);
		if(t) printf("\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值