E - Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting
underground oil deposits. GeoSurvComp works with one large rectangular
region of land at a time, and creates a grid that divides the land
into numerous square plots. It then analyzes each plot separately,
using sensing equipment to determine whether or not the plot contains
oil. A plot containing oil is called a pocket. If two pockets are
adjacent, then they are part of the same oil deposit. Oil deposits can
be quite large and may contain numerous pockets. Your job is to
determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line
containing m and n, the number of rows and columns in the grid,
separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines
of n characters each (not counting the end-of-line characters). Each
character corresponds to one plot, and is either *', representing the
absence of oil, or
@’, representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit
will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@**@*
5 5
**@
@@@
@*@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

-

题目就是让你深搜以下看看有几个不是一起的

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
using namespace std;

int visit[105][105];
char oil[105][105];
int ret = 0;
int m, n;
int dir[8][2] = {1, 0, 0, 1, 1, -1, -1, 1, -1, -1, 1, 1, 0, -1, -1, 0};

void dfs(int x, int y){
    if(visit[x][y] || oil[x][y] != '@'){
        return;
    }

    visit[x][y] = 1;

    for(int i = 0; i < 8; i++){
        int xx = x + dir[i][0];
        int yy = y + dir[i][1];
        if(xx > 0 && xx <= m && yy > 0 && yy <= n){
            dfs(xx, yy);
        }
    }
}




int main(){
    while(cin >> m >> n && m && n){
        memset(visit, 0, sizeof(visit));
        memset(oil, 0, sizeof(oil));
        for(int i = 1; i <= m ;i++){
            for(int j = 1; j <= n; j++){
                cin >> oil[i][j];
            }
        }

        for(int i = 1; i <= m ;i++){
            for(int j = 1; j <= n; j++){
                if(!visit[i][j] && oil[i][j] == '@'){
                    ret++;
                    dfs(i, j);
                }
            }
        }

        cout << ret << endl;
        ret = 0;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值