SDUT 2131 数据结构实验之栈一:进制转换

数据结构实验之栈一:进制转换

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

输入一个十进制整数,将其转换成对应的R(2<=R<=9)进制数,并输出。

输入

第一行输入需要转换的十进制数;
第二行输入R。

输出

输出转换所得的R进制数。

示例输入

1279
8

示例输出

2377

提示

十进制数不断对R取余数后整除,余数入栈,直至十进制数为0,最后依次弹出栈顶元素即可。
#include <bits/stdc++.h>

using namespace std;

typedef int anytype;

struct stacks
{
	struct node
	{
		anytype data;
		struct node *next;
	}*head;
	stacks()
	{
		head=(struct node *)malloc(sizeof(struct node));
		head->next=NULL;
	}
	bool empty()
	{
		if(head->next)
			return false;
		return true;
	}
	void push(anytype n)
	{
		struct node *p;
		p=(struct node *)malloc(sizeof(struct node));
		p->data=n;
		p->next=head->next;
		head->next=p;
	}
	void pop()
	{
		struct node *p;
		p=head->next;
		if(p)
		{
			head->next=p->next;
			free(p);
		}
	}
	anytype top()
	{
		if(!empty())
			return head->next->data;
		return 0;
	}
};
int main()
{
	ios::sync_with_stdio(false);
	int num,r;
	stacks s;
	cin>>num>>r;
	while(num)
	{
		s.push(num%r);
		num/=r;
	}
	while(!s.empty())
	{
		cout<<s.top();
		s.pop();
	}
	cout<<endl;

	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值