POJ 3895 Cycles of Lanes

 

Cycles of Lanes

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1374 Accepted: 502

 

Description

Each of the M lanes of the Park of Polytechnic University of Bucharest connects two of the N crossroads of the park (labeled from 1 to N). There is no pair of crossroads connected by more than one lane and it is possible to pass from each crossroad to each other crossroad by a path composed of one or more lanes. A cycle of lanes is simple when passes through each of its crossroads exactly once. 
The administration of the University would like to put on the lanes pictures of the winners of Regional Collegiate Programming Contest in such way that the pictures of winners from the same university to be on the lanes of a same simple cycle. That is why the administration would like to assign the longest simple cycles of lanes to most successful universities. The problem is to find the longest cycles? Fortunately, it happens that each lane of the park is participating in no more than one simple cycle (see the Figure). 

Input

On the first line of the input file the number T of the test cases will be given. Each test case starts with a line with the positive integers N and M, separated by interval (4 <= N <= 4444). Each of the next M lines of the test case contains the labels of one of the pairs of crossroads connected by a lane.

Output

For each of the test cases, on a single line of the output, print the length of a maximal simple cycle.

Sample Input

1 
7 8 
3 4 
1 4 
1 3 
7 1 
2 7 
7 5 
5 6 
6 2

Sample Output

4

 

把《算法》的无向图部分看完了,于是找到简单的无向图的题练练手。

 

 

题意是让你计算出几幅无向图的最大环的长度。

输入:

1(用例的个数)

7 8(顶点的数量 边的数量)

3 4(顶点3到顶点4之间存在边)

1 4(顶点1到顶点4之间存在边)

……

输出:

4(最大环的长度)

 

思路是:先把图存下来,然后使用深度优先搜索计算最大环的长度。这里使用了面向对象的方法,把无向图和环分别封装成一个类,无向图的对象需要调用方法完成无向图的初始化,而环的对象在构造时便使用深度优先搜索计算好了最大环的长度,而且用实例域记录了下来。所以输出时只要调用环的对象的getter方法即可。

 

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

/**
 * Created by 小粤 on 2015/9/4.
 */

public class Main
{
    public static void main(String[] args)
    {
        Scanner scanner = new Scanner(System.in);
        int numberOfTestCases = scanner.nextInt();
        for (int i = 0; i < numberOfTestCases; i++)
        {
            Graph graph = new Graph(scanner.nextInt());
            int edge = scanner.nextInt();
            for (int j = 0; j < edge; j++)
            {
                graph.addEdge(scanner.nextInt() - 1, scanner.nextInt() - 1); // 此处把输入纠正(1->0, 3->2, 14->13...)
            }

            Cycle cycle = new Cycle(graph);
            System.out.println(cycle.getMaxLengthOfCycle());
        }
    }
}

class Graph
{
    private final int V; // 顶点数目
    private int E; // 边数目
    private List[] adj; // 邻接表

    /**
     * 构造器
     * 初始化一个定点数为v边数为0的图
     *
     * @param v 顶点数目
     */
    public Graph(int v)
    {
        V = v;
        E = 0;
        adj = new List[v];
        for (int i = 0; i < adj.length; i++)
        {
            adj[i] = new ArrayList<Integer>();
        }
    }

    /**
     * 返回顶点数目
     *
     * @return 顶点数目
     */
    public int V()
    {
        return V;
    }

    /**
     * 返回边的数目
     *
     * @return 边的数目
     */
    public int E()
    {
        return E;
    }

    /**
     * 添加新的边
     *
     * @param v 边的一个顶点
     * @param w 边的另一个顶点
     */
    public void addEdge(int v, int w)
    {
        E++;
        adj[v].add(w);
        adj[w].add(v);
    }

    /**
     * 获取顶点v的邻接表
     *
     * @param v 要获取邻接表的顶点
     * @return 邻接表
     */
    public Iterable<Integer> adj(int v)
    {
        return adj[v];
    }
}

class Cycle
{
    private boolean[] marked; // 标记顶点是否已经访问过

    private int[] number; // 每个顶点的序号,根据深度优先搜索的顺序编号
    private int maxLengthOfCycle; // 最大环的长度

    /**
     * 构造器
     * 通过深度优先搜索,初始化相关参数
     *
     * @param graph 要搜索的图
     */
    public Cycle(Graph graph)
    {
        marked = new boolean[graph.V()];
        number = new int[graph.V()];
        for (int i = 0; i < graph.V(); i++)
        {
            if (!marked[i])
            {
                number[i] = 1; // 根据深度优先搜索的顺序编号
                dfs(graph, i, i);
            }
        }
    }

    /**
     * 深度优先搜索
     *
     * @param graph 要搜索的图
     * @param v     要搜索的顶点
     * @param u     要搜索的顶点的上一个顶点
     */
    private void dfs(Graph graph, int v, int u)
    {
        marked[v] = true;
        for (Integer w : graph.adj(v))
        {
            if (!marked[w])
            {
                number[w] = number[v] + 1; // 根据深度优先搜索的顺序编号
                dfs(graph, w, v);
            }
            else if (w != u) // 说明该图有环
            {
                if (maxLengthOfCycle < number[v] - number[w] + 1)
                {
                    maxLengthOfCycle = number[v] - number[w] + 1;
                }
            }
        }
    }

    /**
     * 返回最大环的长度
     *
     * @return 最大环的长度
     */
    public int getMaxLengthOfCycle()
    {
        return maxLengthOfCycle;
    }
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值