C++按由小到大的顺序输出三个数

【问题描述】在main函数中输入三个整数,并调用函数fun1实现在fun1中按由小到大的顺序输出这三个数。
【输入形式】输入三个数
【输出形式】输出排序后的三个数
【样例输入】3 6 -1
【样例输出】 please input three number:

       the result after sorting is -1 3 6 

//按由小到大的顺序输出三个数
#include<iostream>
using namespace std;
void fun1(int a,int b,int c)
{
	int *a1=&a,*b1=&b,*c1=&c;
	int t=0;
	if(*a1>*b1)
	{
	    t=*a1;*a1=*b1;*b1=t;
    }
    if(*a1>*c1)
	{
	    t=*a1;*a1=*c1;*c1=t;
    }
    if(*b1>*c1)
	{
	    t=*b1;*b1=*c1;*c1=t;
    }//三个数排序完成
    cout<<*a1<<" "<<*b1<<" "<<*c1<<endl;
}
int main()
{
	int a,b,c;
	cout<<"please input three number:"<<endl;
	cin>>a>>b>>c;
	cout<<"the result after sorting is ";
	fun1(a,b,c);
	return 0;
}

  • 1
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值