FOJ 2110 Star

Problem Description

Overpower often go to the playground with classmates. They play and chat on the playground. One day, there are a lot of stars in the sky. Suddenly, one of Overpower’s classmates ask him: “How many acute triangles whose inner angles are less than 90 degrees (regarding stars as points) can be found? Assuming all the stars are in the same plane”. Please help him to solve this problem.

Input

The first line of the input contains an integer T (T≤10), indicating the number of test cases.

For each test case:

The first line contains one integer n (1≤n≤100), the number of stars.

The next n lines each contains two integers x and y (0≤|x|, |y|≤1,000,000) indicate the points, all the points are distinct.

Output

For each test case, output an integer indicating the total number of different acute triangles.

Sample Input

130 010 05 1000

Sample Output

 
给你一些点叫你求你能构成锐角三角形的个数,a, b, c三条边,a^2+b^2<c^2&&a^2+c^2<b^2&&c^2+b^2<a^2即可
 
AC代码:
 
# include <stdio.h>
typedef long long int ll;
struct node {
	ll x, y;
};
node s[110];
ll func(node a, node b){
	return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}
int main(){
	int t, n, i, j, k;
	ll a, b, c;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		for(i=1; i<=n; i++){
			scanf("%I64d%I64d", &s[i].x, &s[i].y);
		}
		if(n<=2){
			printf("0\n");
			continue;
		}
		int ans=0;
		for(i=1; i<=n-2; i++){
			for(j=i+1; j<=n-1; j++){
				for(k=j+1; k<=n; k++){
					a=func(s[i], s[j]);
					b=func(s[i], s[k]);
					c=func(s[j], s[k]);
					if(a+b>c&&a+c>b&&b+c>a){
						ans++;
					}
				}
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值