题目描述
本题要求实现一个简易连连看游戏模拟程序:给定一个N×N(2≤N≤20且N为偶数)的方阵网格游戏盘面,每个格子中放置一个符号。这些符号一定是成对出现的,同一个符号可能不止一对。程序读入玩家给出的一对位置(x1,y1)、(x2,y2)(1≤x1,x2,y1,y2≤20),判断这两个位置上的符号是否匹配。如果匹配成功(位置不同且相同符号,不为“*”),则将两个符号消为“*”。若匹配错误达到3次,则输出“Game Over”并结束游戏。或者当全部符号匹配成功,即每个格子里都是“*”时,则输出“Congratulations”,然后结束游戏。 请用类CGame模拟该游戏,游戏会运行多次。请在类中设置一个私有的静态变量counter,记录游戏一共赢了多少次。
注:初始游戏盘面无“*”。
输入
第一行输入测试次数
每次测试输入格式如下:第1行是盘面大小N;第2行到第N+1行是每行的N个符号;第N+2行是位置对的次数M;第N+3行到第N+M+2行是一对位置(x1,y1)、(x2,y2)的值。
输出
每次测试数据输出一行游戏结果(Game Over或Congratulations)。 最后一行输出游戏共赢了多少次。
输入样例:
2
4
I T I T
Y T I A
T A T Y
I K K T
11
1 1 1 3
4 2 4 3
3 1 4 2
2 2 1 2
3 1 2 4
4 4 3 1
2 1 3 4
3 3 1 4
4 1 2 3
2 4 3 2
1 1 2 2
4
I T I T
Y T I A
T A T Y
I K K T
6
1 1 1 1
1 1 4 4
1 1 2 3
1 1 2 3
2 2 4 1
2 2 3 3
输出样例:
Congratulations
Game Over
一定要注意*的比对不能增加正确数,判断出全对或者gameover后一定要打上tag防止两种情况都给判断了!
#include <iostream>
using namespace std;
class CGame {
static int count;
int total = 0;
int wrong = 0;
char **p;
int n;
public:
void openboard(int nn) {
n = nn;
p = new char *[n];
for (int i = 0; i < n; i++) {
p[i] = new char[n];
}
for (int i = 0; i < n; i++) {
for (int j = 0; j < n; j++) {
cin >> p[i][j];
}
}
int x1, y1, x2, y2, t;
int tag = 0;
cin >> t;
while (t--) {
cin >> x1 >> y1 >> x2 >> y2;
x1--;
y1--;
x2--;
y2--;
if (p[x1][y1] == p[x2][y2] && p[x1][y1] != '*' && p[x2][y2] != '*') {
p[x1][y1] = '*';
total++;
p[x2][y2] = '*';
total++;
} else {
wrong++;
}
if (wrong == 3) {
if (tag == 0) {
tag = -1;
}
}
if (total >= n * n ) {
if (tag == 0) {
tag = 1;
}
}
}
if (tag == 1) {
cout << "Congratulations" << endl;
count++;
}
if (tag == -1) {
cout << "Game Over" << endl;
}
}
void print() {
cout << count << endl;
}
};
int CGame::count = 0;
int main() {
int t, n, m, t1;
cin >> t;
while (t--) {
cin >> n;
CGame obj;
obj.openboard(n);
if (t == 0) {
obj.print();
}
}
}