POJ 1836 Alignment

链接:http://poj.org/problem?id=1836

Alignment

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14457 Accepted: 4690

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.


Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
• 2 <= n <= 1000
• the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source
Romania OI 2002

大意——从队伍中抽取一些人,使得留下的每个人至少能从一边看到尽头。问:给定一个数n,表示队伍的长度,又已知队员的各自身高,求抽走的最小人数满足以上条件。

思路——问题转化为求一列数从中间到两端严格递减的最长数目。那么我们可以分别求出这列数从左到右和从右到左的最长递增子序列,然后得到从中间到两端递减的最长序列所以此与POJ 2533类似。结果即为n减去这个最长序列的长度。

复杂度分析——时间复杂度:O(n^2),空间复杂度:O(n)

附上AC代码:


#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <map>
using namespace std;
typedef unsigned int UI;
typedef long long LL;
typedef unsigned long long ULL;
typedef long double LD;
const double pi = acos(-1.0);
const double e = exp(1.0);
const int maxn = 1005;
int prev[maxn], next[maxn]; // 分别代表从左、右边开始的LIS长度
double high[maxn]; // 士兵的身高

int main()
{
	ios::sync_with_stdio(false);
	int n;
	while (scanf("%d", &n) != EOF)
	{
		for (int i=0; i<n; i++)
			scanf("%lf", &high[i]);
		prev[0] = next[n-1] = 1;
		for (int i=1; i<n; i++)
		{ // 从左边求LIS长度
			prev[i] = 1;
			for (int j=0; j<i; j++)
				if (high[j] < high[i])
					prev[i] = max(prev[i], prev[j]+1);
		}
		for (int i=n-2; i>=0; i--)
		{ // 从右边求LIS长度
			next[i] = 1;
			for (int j=n-1; j>i; j--)
				if (high[j] < high[i])
					next[i] = max(next[i], next[j]+1);
		}
		int ans = 0;
		for (int i=0; i<n-1; i++)
			for (int j=i+1; j<n; j++)
				ans = max(ans, prev[i]+next[j]);
		printf("%d\n", n-ans);
	}
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值